summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Anhuth2017-10-25 14:53:57 +0200
committerOliver Anhuth2017-10-25 14:53:57 +0200
commit918b6523588159272af86d25757e9fd038a66eb5 (patch)
tree6c03bf64d726813de3e834659bbd4319dd71306c
parente25588b1ebfbf8338c395aefd43a43d279dcec14 (diff)
downloadaur-918b6523588159272af86d25757e9fd038a66eb5.tar.gz
0.14.4
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 498c76880053..d4e698d63d8d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = albert-lite
pkgdesc = A sophisticated standalone keyboard launcher. Without QML and VirtualBox dependencies
- pkgver = 0.14.3
+ pkgver = 0.14.4
pkgrel = 1
url = https://github.com/albertlauncher
arch = i686
@@ -19,7 +19,7 @@ pkgbase = albert-lite
provides = albert
conflicts = albert-git
conflicts = albert
- source = mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v0.14.3
+ source = mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v0.14.4
source = mirrors/plugins::git+https://github.com/albertlauncher/plugins.git
source = mirrors/python::git+https://github.com/albertlauncher/python.git
source = mirrors/pybind11::git+https://github.com/pybind/pybind11.git
diff --git a/PKGBUILD b/PKGBUILD
index f15ec9bf1415..e84b123f2c1f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Manuel Schneider <manuelschneid3r at googles mail>
pkgname=albert-lite
-pkgver=0.14.3
+pkgver=0.14.4
pkgrel=1
pkgdesc="A sophisticated standalone keyboard launcher. Without QML and VirtualBox dependencies"
arch=('i686' 'x86_64' 'armv7h')
@@ -64,7 +64,9 @@ build() {
cmake \
"../albert" \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_BUILD_TYPE="MinSizeRel" \
+ -Wno-dev \
-DBUILD_WIDGETBOXMODEL=ON \
-DBUILD_QMLBOXMODEL=OFF \
-DBUILD_APPLICATIONS=ON \
@@ -77,14 +79,13 @@ build() {
-DBUILD_HASHGENERATOR=ON \
-DBUILD_KVSTORE=ON \
-DBUILD_MPRIS=ON \
- -DBUILD_PYTHON=OFF \
+ -DBUILD_PYTHON=ON \
-DBUILD_SSH=ON \
-DBUILD_SYSTEM=ON \
-DBUILD_TEMPLATE=OFF \
-DBUILD_TERMINAL=ON \
- -DBUILD_VIRTUALBOX=OFF \
- -Wno-dev
- make -j $((`nproc`+1))
+ -DBUILD_VIRTUALBOX=OFF
+ VERBOSE=1 make -j $((`nproc`+1))
}