summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUffe Jakobsen2021-02-03 05:21:06 +0100
committerUffe Jakobsen2021-02-03 05:21:06 +0100
commitd5560865d3aa337792f3e1ee83e9f15c173f63bb (patch)
tree243aae0f5147df7eda64dd8914eb9b148b03627a
downloadaur-d5560865d3aa337792f3e1ee83e9f15c173f63bb.tar.gz
Initial - save deleted PKGBUILD from arch community
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD90
2 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..86762963e1a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = albert-minimal
+ pkgdesc = A sophisticated standalone keyboard launcher - minimal plugins included
+ pkgver = 0.17.2
+ pkgrel = 1
+ url = https://github.com/albertlauncher
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = muparser
+ makedepends = python
+ makedepends = qt5-declarative
+ makedepends = qt5-svg
+ makedepends = virtualbox
+ makedepends = virtualbox-sdk
+ depends = qt5-charts
+ depends = qt5-graphicaleffects
+ depends = qt5-quickcontrols
+ depends = qt5-svg
+ depends = qt5-x11extras
+ depends = libx11
+ optdepends = muparser: Calculator plugin
+ optdepends = python: Python extension
+ source = mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v0.17.2
+ source = mirrors/plugins::git+https://github.com/albertlauncher/plugins.git
+ source = mirrors/python::git+https://github.com/albertlauncher/python.git
+ source = mirrors/pybind11::git+https://github.com/pybind/pybind11.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = albert-minimal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2c0bff52ef00
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,90 @@
+# Maintainer: Uffe Jakobsen
+# Contributor: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Manuel Schneider <manuelschneid3r at googles mail>
+
+pkgname=albert-minimal
+pkgver=0.17.2
+pkgrel=1
+pkgdesc="A sophisticated standalone keyboard launcher - minimal plugins included"
+arch=('x86_64')
+url="https://github.com/albertlauncher"
+license=('GPL')
+depends=('qt5-charts' 'qt5-graphicaleffects' 'qt5-quickcontrols' 'qt5-svg' 'qt5-x11extras' 'libx11')
+makedepends=( 'cmake' 'git' 'muparser' 'python' 'qt5-declarative' 'qt5-svg' 'virtualbox' 'virtualbox-sdk')
+optdepends=('muparser: Calculator plugin'
+ 'python: Python extension'
+ #'virtualbox: VirtualBox plugin'
+ )
+source=("mirrors/albert::git+https://github.com/albertlauncher/albert.git#tag=v${pkgver}"
+ "mirrors/plugins::git+https://github.com/albertlauncher/plugins.git"
+ "mirrors/python::git+https://github.com/albertlauncher/python.git"
+ "mirrors/pybind11::git+https://github.com/pybind/pybind11.git")
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+#
+#
+#
+prepare()
+{
+ mkdir -p build
+
+ cd "${srcdir}/albert"
+ git submodule init
+ git config submodule.plugins.url "${srcdir}/plugins"
+ git submodule update plugins
+
+ cd "${srcdir}/albert/plugins"
+ git submodule init
+ git config submodule.python/pybind11.url "${srcdir}/pybind11"
+ git config submodule.python/share/modules.url "${srcdir}/python"
+ git submodule update python/pybind11 python/share/modules
+}
+
+
+#
+#
+#
+build()
+{
+ cd build
+
+ cmake "../albert" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -Wno-dev \
+ -DBUILD_WIDGETBOXMODEL=ON \
+ -DBUILD_QMLBOXMODEL=ON \
+ -DBUILD_APPLICATIONS=ON \
+ -DBUILD_CALCULATOR=ON \
+ -DBUILD_CHROMEBOOKMARKS=ON \
+ -DBUILD_EXTERNALEXTENSIONS=ON \
+ -DBUILD_DEBUG=OFF \
+ -DBUILD_FILES=ON \
+ -DBUILD_FIREFOXBOOKMARKS=ON \
+ -DBUILD_HASHGENERATOR=ON \
+ -DBUILD_KVSTORE=ON \
+ -DBUILD_MPRIS=ON \
+ -DBUILD_PYTHON=ON \
+ -DBUILD_SSH=ON \
+ -DBUILD_SYSTEM=ON \
+ -DBUILD_TEMPLATE=OFF \
+ -DBUILD_TERMINAL=ON \
+ -DBUILD_VIRTUALBOX=OFF
+
+ make
+}
+
+#
+#
+#
+package()
+{
+ cd build
+ make DESTDIR="${pkgdir}/" install
+}
+
+# vim:set ts=2 sw=2 et:
+# EOF