summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAsger Hautop Drewsen2017-10-04 01:23:07 +0200
committerAsger Hautop Drewsen2017-10-04 01:24:45 +0200
commit89ae7c55898017dbd258f430ceefdcd2295fdd97 (patch)
tree07c19fe204159bcb621c927f21c1dcd4e40159d6
downloadaur-89ae7c55898017dbd258f430ceefdcd2295fdd97.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD21
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..17fcc4c3bd02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = albert-tex-to-unicode
+ pkgdesc = Albert extension for converting tex math to unicode symbols
+ pkgver = r17.d755a27
+ pkgrel = 1
+ url = https://github.com/Tyilo/albert-extensions
+ arch = any
+ license = GPL
+ depends = albert
+ depends = python
+ depends = python-pylatexenc
+ optdepends = xclip
+ source = git+https://github.com/Tyilo/albert-extensions
+ md5sums = SKIP
+
+pkgname = albert-tex-to-unicode
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95767e39c028
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Asger Hautop Drewsen <asgerdrewsen@gmail.com>
+pkgname=albert-tex-to-unicode
+pkgver=r17.d755a27
+pkgrel=1
+pkgdesc="Albert extension for converting tex math to unicode symbols"
+arch=('any')
+url="https://github.com/Tyilo/albert-extensions"
+license=('GPL')
+depends=('albert' 'python' 'python-pylatexenc')
+optdepends=('xclip')
+source=("git+https://github.com/Tyilo/albert-extensions")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/albert-extensions"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ install -D "${srcdir}/albert-extensions/unicode_tex.py" "${pkgdir}/usr/share/albert/org.albert.extension.externalextensions/extensions/unicode_tex.py"
+}