summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeancahu2022-09-12 02:11:57 -0600
committerJeancahu2022-09-12 02:11:57 -0600
commit41d8f3965e1742fa659dbf4758776e0b172eb12d (patch)
tree352e6590ec81d81ce7dc5409dcc04ed0ac41ccfb
parented6c17a29f3ca611594823f9f37d13be604179fa (diff)
downloadaur-41d8f3965e1742fa659dbf4758776e0b172eb12d.tar.gz
restrict others privileges on /opt/albion {game data}
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
-rwxr-xr-xalbion-online10
3 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6766475f3a8a..571879dd901d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = albion-online-launcher-bin
pkgdesc = The first true cross-platform Sandbox MMO -- launcher client
pkgver = 1.17
- pkgrel = 3
+ pkgrel = 4
url = https://albiononline.com/
install = albion-online-launcher-bin.install
arch = x86_64
@@ -16,6 +16,7 @@ pkgbase = albion-online-launcher-bin
depends = qt5-webengine
depends = xdelta3
depends = ttf-font
+ depends = zenity
options = !strip
options = docs
options = libtool
diff --git a/PKGBUILD b/PKGBUILD
index ddf6e8ad19c2..82432137ccfc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=albion-online-launcher-bin
pkgver=1.17
-pkgrel=3
+pkgrel=4
pkgdesc="The first true cross-platform Sandbox MMO -- launcher client"
url="https://albiononline.com/"
arch=('x86_64')
@@ -20,6 +20,7 @@ depends=(
'qt5-webengine'
'xdelta3'
'ttf-font'
+ 'zenity'
)
optdepends=()
source=("https://live.albiononline.com/clients/20220825102752/albion-online-setup"
@@ -46,10 +47,10 @@ prepare() {
package() {
mkdir -p "${pkgdir}/opt"
cp -a "${srcdir}/data" "${pkgdir}/opt/${pkgname}"
- chmod 777 "$pkgdir/opt/${pkgname}"
+ chmod 755 "$pkgdir/opt/${pkgname}"
mkdir -p "${pkgdir}/opt/${pkgname}/game_x64"
- chmod 6777 "${pkgdir}/opt/${pkgname}/game_x64"
+ chmod 6775 "${pkgdir}/opt/${pkgname}/game_x64"
# Link launcher to usr/system binaries directory
mkdir -p "${pkgdir}/usr/bin"
diff --git a/albion-online b/albion-online
index f394c99a64bd..bebb8ff806a6 100755
--- a/albion-online
+++ b/albion-online
@@ -1,2 +1,10 @@
#!/bin/bash
- /opt/albion-online-launcher-bin/Albion-Online
+
+if newgrp albion &>/dev/null <<< /opt/albion-online-launcher-bin/Albion-Online
+then
+ :
+else
+ zenity \
+ --info \
+ --text="Please run the next command in your terminal to give your user permissions to update Albion game data on /opt:\n\n\sudo usermod -a -G albion ${USER}"
+fi