summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeancahu2022-09-14 13:54:40 -0600
committerJeancahu2022-09-14 13:54:40 -0600
commit614cbb8b823b466111ee932e06a43d7d37c600b3 (patch)
tree2556a0d021d5e7ac9c3d98816d1adc060dbdfd7d
parent8dc5e5db3b9e3282d6f5996d918bcd5eed720753 (diff)
downloadaur-614cbb8b823b466111ee932e06a43d7d37c600b3.tar.gz
update: 1.20.060.231052
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 26 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b1f4df5c9f9..ea048cce9828 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = albion-online-launcher-bin
pkgdesc = The first true cross-platform Sandbox MMO -- launcher client
- pkgver = 1.20.050.229341
- pkgrel = 1
+ pkgver = 1.20.060.231052
+ pkgrel = 2
url = https://albiononline.com/
install = albion-online-launcher-bin.install
arch = x86_64
license = custom
+ makedepends = chrpath
depends = libgl
depends = alsa-lib
depends = libxrandr
+ depends = libxcb
+ depends = libxkbcommon
+ depends = sdl2
depends = qt5-base
depends = qt5-declarative
depends = qt5-location
@@ -23,11 +27,11 @@ pkgbase = albion-online-launcher-bin
options = emptydirs
options = !zipman
options = staticlibs
- source = https://live.albiononline.com/clients/20220825102752/albion-online-setup
+ source = https://live.albiononline.com/clients/20220914103045/albion-online-setup
source = albion-online-launcher.desktop
source = albion-online
source = Albion-Online.patch
- sha256sums = 89f4b80b77984cc304b4af6a6b8bdea95dcf3395521cda160ed22c947c19e006
+ sha256sums = 0ef7ea10ce92d10ba2ba3ed62d861ef6bdbf72c6c9418ebbdbe0c19e80b760c4
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7bcaf5d6c36f..afa897077457 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,20 @@
# Maintainer: Jeancarlo Hidalgo <jeancahu@gmail.com>
pkgname=albion-online-launcher-bin
-pkgver=1.20.050.229341
-pkgrel=1
+pkgver=1.20.060.231052
+pkgrel=2
pkgdesc="The first true cross-platform Sandbox MMO -- launcher client"
url="https://albiononline.com/"
arch=('x86_64')
license=('custom')
-makedepends=()
+makedepends=(chrpath)
depends=(
'libgl'
'alsa-lib'
'libxrandr'
+ 'libxcb'
+ 'libxkbcommon'
+ 'sdl2'
'qt5-base'
'qt5-declarative'
'qt5-location'
@@ -23,16 +26,22 @@ depends=(
'zenity'
)
optdepends=()
-source=("https://live.albiononline.com/clients/20220825102752/albion-online-setup"
+source=("https://live.albiononline.com/clients/20220914103045/albion-online-setup"
"albion-online-launcher.desktop" "albion-online" "Albion-Online.patch")
install=albion-online-launcher-bin.install
options=(!strip docs libtool emptydirs !zipman staticlibs)
-sha256sums=('89f4b80b77984cc304b4af6a6b8bdea95dcf3395521cda160ed22c947c19e006'
+sha256sums=('0ef7ea10ce92d10ba2ba3ed62d861ef6bdbf72c6c9418ebbdbe0c19e80b760c4'
'SKIP' 'SKIP' 'SKIP')
prepare() {
+ chrpath -d "${srcdir}/data/launcher/Albion-Online"
+
pushd "${srcdir}/data/launcher"
- rm libQt5* qt.conf xdelta3 QtWebEngineProcess libicu*
+ rm libQt5* qt.conf xdelta3 QtWebEngineProcess libicu* \
+ libSDL2-2.0.so.0 libSDL2-2.0.so \
+ libcrypto.so libssl.so libxkbcommon* libxcb*
+
+ rm -r resources plugins translations
popd
pushd "${srcdir}/data"
@@ -48,6 +57,9 @@ package() {
mkdir -p "${pkgdir}/opt/${pkgname}/game_x64"
chmod 2775 "${pkgdir}/opt/${pkgname}/game_x64"
+ ## Give albion group permission to update the launcher
+ chmod 2775 "${pkgdir}/opt/${pkgname}/launcher"
+
# Link launcher to usr/system binaries directory
mkdir -p "${pkgdir}/usr/bin"
install -m755 -D "${srcdir}/albion-online" "${pkgdir}/usr/bin"