summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeancahu2022-09-13 14:21:59 -0600
committerJeancahu2022-09-13 14:21:59 -0600
commit8dc5e5db3b9e3282d6f5996d918bcd5eed720753 (patch)
treee7bee5f05b0999e8eabf5921b4b1ea53b508e89a
parent41d8f3965e1742fa659dbf4758776e0b172eb12d (diff)
downloadaur-8dc5e5db3b9e3282d6f5996d918bcd5eed720753.tar.gz
update version to match the current one
-rw-r--r--.SRCINFO4
-rw-r--r--Albion-Online.patch22
-rw-r--r--PKGBUILD14
-rwxr-xr-xalbion-online35
4 files changed, 50 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 571879dd901d..0b1f4df5c9f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = albion-online-launcher-bin
pkgdesc = The first true cross-platform Sandbox MMO -- launcher client
- pkgver = 1.17
- pkgrel = 4
+ pkgver = 1.20.050.229341
+ pkgrel = 1
url = https://albiononline.com/
install = albion-online-launcher-bin.install
arch = x86_64
diff --git a/Albion-Online.patch b/Albion-Online.patch
index 0ae43b444a11..3a7d3ae9615f 100644
--- a/Albion-Online.patch
+++ b/Albion-Online.patch
@@ -1,6 +1,6 @@
---- old 2022-09-11 19:50:08.965753712 -0600
-+++ Albion-Online 2022-09-11 19:47:06.444974351 -0600
-@@ -1,16 +1,21 @@
+--- old 2022-08-09 09:07:35.000000000 -0600
++++ new 2022-09-13 13:54:49.424249375 -0600
+@@ -1,16 +1,25 @@
#!/bin/sh
SCRIPT=$(readlink -f "$0")
SCRIPTPATH=$(dirname "$SCRIPT")
@@ -16,19 +16,23 @@
-export QT_QPA_PLATFORM="xcb;eglfs"
-export __GL_GlslUseCollapsedArrays=0
-"$SCRIPTPATH/launcher/Albion-Online" "--no-sandbox" "$@" &
++
++LD_PRELOAD=\
++/opt/albion-online-launcher-bin/launcher/libsteam_api.so \
+"$SCRIPTPATH/launcher/Albion-Online" "--no-sandbox" "-loglevel 0" "$@"
+
+declare exit_code=$?
++declare core_dump_msg="Core Dump can be produced by corrupt cache
++Clear user cache/configuration and try again!
++\trm -rf \"$HOME/.config/Sandbox Interactive GmbH\"
++\trm -rf \"$HOME/.config/unity3d/Sandbox Interactive GmbH\"
++\trm -rf \"$HOME/.local/share/Sandbox Interactive GmbH/Albion Online Launcher\"
++"
+
+## Clear cache on core dump
+if (( $exit_code )); then
+ echo "Bad exit code: $exit_code"
+ if (( $exit_code >= 128 )); then ## Core Dump
-+ echo "Core Dump can be produced by corrupt cache"
-+ echo "Clearing user cache, you could try again"
-+ rm -rf "$HOME/.config/Sandbox Interactive GmbH"
-+ rm -rf "$HOME/.config/unity3d/Sandbox Interactive GmbH"
-+ rm -rf "$HOME/.local/share/Sandbox Interactive GmbH/Albion Online Launcher"
++ printf "$core_dump_msg"
+ fi
fi
-+
diff --git a/PKGBUILD b/PKGBUILD
index 82432137ccfc..7bcaf5d6c36f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jeancarlo Hidalgo <jeancahu@gmail.com>
pkgname=albion-online-launcher-bin
-pkgver=1.17
-pkgrel=4
+pkgver=1.20.050.229341
+pkgrel=1
pkgdesc="The first true cross-platform Sandbox MMO -- launcher client"
url="https://albiononline.com/"
arch=('x86_64')
@@ -27,12 +27,8 @@ source=("https://live.albiononline.com/clients/20220825102752/albion-online-setu
"albion-online-launcher.desktop" "albion-online" "Albion-Online.patch")
install=albion-online-launcher-bin.install
options=(!strip docs libtool emptydirs !zipman staticlibs)
-sha256sums=(
- '89f4b80b77984cc304b4af6a6b8bdea95dcf3395521cda160ed22c947c19e006'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
+sha256sums=('89f4b80b77984cc304b4af6a6b8bdea95dcf3395521cda160ed22c947c19e006'
+ 'SKIP' 'SKIP' 'SKIP')
prepare() {
pushd "${srcdir}/data/launcher"
@@ -50,7 +46,7 @@ package() {
chmod 755 "$pkgdir/opt/${pkgname}"
mkdir -p "${pkgdir}/opt/${pkgname}/game_x64"
- chmod 6775 "${pkgdir}/opt/${pkgname}/game_x64"
+ chmod 2775 "${pkgdir}/opt/${pkgname}/game_x64"
# Link launcher to usr/system binaries directory
mkdir -p "${pkgdir}/usr/bin"
diff --git a/albion-online b/albion-online
index bebb8ff806a6..fd48599a7116 100755
--- a/albion-online
+++ b/albion-online
@@ -1,10 +1,35 @@
#!/bin/bash
-if newgrp albion &>/dev/null <<< /opt/albion-online-launcher-bin/Albion-Online
+declare no_group="Please run the next command in your terminal to give your user permissions to update Albion game data on /opt:\n\nsudo usermod -a -G albion ${USER}"
+declare no_sudo="Don't run this game as root(sudo)!! it could be a security risk!"
+
+if [[ "$USER" == "root" ]]; then
+ if zenity \
+ --info \
+ --text="$no_sudo"; then :
+ else
+ ## Zenity is not installed
+ printf "${no_sudo}\n"
+ fi
+ exit 1
+fi
+
+if which newgrp; then :
+else
+ echo "A core package \"util-linux\" is required"
+ exit 2
+fi
+
+if (( $( id -nG "$USER" | grep -c '\balbion\b' ) )) # Does the user have the permissions to run as group albion?
then
- :
+ newgrp albion <<< /opt/albion-online-launcher-bin/Albion-Online
else
- zenity \
- --info \
- --text="Please run the next command in your terminal to give your user permissions to update Albion game data on /opt:\n\n\sudo usermod -a -G albion ${USER}"
+ if zenity \
+ --info \
+ --text="$no_group"; then :
+ else
+ ## Zenity is not installed
+ printf "${no_group}\n"
+ fi
+ exit 4
fi