summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2017-07-25 00:14:07 +0100
committerGrey Christoforo2017-07-25 00:14:07 +0100
commitd2b51f8132652d5fee551855ccc4595166be651b (patch)
treeff9f55d1027f1eb7126087d419fcf88533b46001
parent9a9dba4db2878e8eb15577ba4e52a8bff964f29d (diff)
downloadaur-d2b51f8132652d5fee551855ccc4595166be651b.tar.gz
fixing up, version bump
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD42
-rw-r--r--albion-online-launcher-bin.install14
4 files changed, 52 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3f6ab9190af..9f7b6be33a07 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
# Generated by mksrcinfo v8
-# Sun Jul 23 23:33:36 UTC 2017
+# Mon Jul 24 23:14:04 UTC 2017
pkgbase = albion-online-launcher-bin
pkgdesc = The first true cross-platform Sandbox MMO -- launcher client
- pkgver = 1.0.34.156
- pkgrel = 3
+ pkgver = 1.0.34.160
+ pkgrel = 1
url = https://albiononline.com/
+ install = albion-online-launcher-bin.install
arch = x86_64
license = custom
+ makedepends = chrpath
depends = libgl
depends = qt5-webengine
+ depends = sndio
+ depends = xdelta3
+ depends = ttf-font
optdepends = albion-online-live-game-data-bin
optdepends = albion-online-staging-game-data-bin
options = !strip
@@ -18,9 +23,9 @@ pkgbase = albion-online-launcher-bin
options = !zipman
options = staticlibs
options = !upx
- source = albion-online-launcher-bin-1.0.34.156.zip::https://live.albiononline.com/clients//albion-online-setup
+ source = https://live.albiononline.com/autoupdate/launcher-linux-setup-1.0.34.160
source = albion-online-launcher.desktop
- md5sums = 19756c7be3be70eba49a8cc36d6aae90
+ md5sums = 9eb391651e1a06163d605af4b2ffac9f
md5sums = 14b5dfae0a7b3b0dc5e2f2975aa4892c
pkgname = albion-online-launcher-bin
diff --git a/.gitignore b/.gitignore
index 50adc9213e87..c3ade44812f1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,6 +2,7 @@
*.pkg.tar.xz
*.tar.xz
*.zip
+launcher-linux-setup*
albion-online-setup
pkg/
src/
diff --git a/PKGBUILD b/PKGBUILD
index 0173fe8a3aed..2fa18306f326 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,30 +1,39 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=albion-online-launcher-bin
-pkgver=1.0.34.156
-pkgrel=3
+pkgver=1.0.34.160
+pkgrel=1
pkgdesc="The first true cross-platform Sandbox MMO -- launcher client"
url="https://albiononline.com/"
arch=('x86_64')
license=('custom')
-depends=('libgl' 'qt5-webengine')
+makedepends=('chrpath')
+depends=('libgl' 'qt5-webengine' 'sndio' 'xdelta3' 'ttf-font')
optdepends=(albion-online-live-game-data-bin albion-online-staging-game-data-bin)
-source=(${pkgname}-${pkgver}.zip::"https://live.albiononline.com/clients//albion-online-setup" "albion-online-launcher.desktop")
+source=("https://live.albiononline.com/autoupdate/launcher-linux-setup-${pkgver}" "albion-online-launcher.desktop")
+
+install=albion-online-launcher-bin.install
options=(!strip docs libtool emptydirs !zipman staticlibs !upx)
-md5sums=('19756c7be3be70eba49a8cc36d6aae90'
+md5sums=('9eb391651e1a06163d605af4b2ffac9f'
'14b5dfae0a7b3b0dc5e2f2975aa4892c')
prepare() {
+ chrpath -d "${srcdir}/data/launcher/Albion-Online"
+
pushd "${srcdir}/data/launcher"
rm libQt5* qt.conf xdelta3 QtWebEngineProcess libicu*
popd
pushd "${srcdir}/data"
- sed -i 's,export LD_LIBRARY_PATH=.*,export LD_LIBRARY_PATH=/usr/lib,g' Albion-Online
- sed -i 's,export QT_QPA_PLATFORM_PLUGIN_PATH=.*,export QT_QPA_PLATFORM_PLUGIN_PATH=/usr/lib/qt/plugins/platforms,g' Albion-Online
- sed -i 's,export QT_PLUGIN_PATH=.*,export QT_PLUGIN_PATH=/usr/lib/qt/plugins,g' Albion-Online
- sed -i 's,.*launcher/Albion-Online" &,LD_PRELOAD=/opt/albion-online-launcher-bin/game_x64/Albion-Online_Data/Plugins/x86_64/libSDL2-2.0.so.0 "$SCRIPTPATH/launcher/Albion-Online" &,g' Albion-Online
+ sed -i '/export LD_LIBRARY_PATH=.*/d' Albion-Online
+ sed -i '/export QT_QPA_PLATFORM_PLUGIN_PATH=.*/d' Albion-Online
+ sed -i '/export QT_PLUGIN_PATH=.*/d' Albion-Online
+
+ #sed -i 's,export LD_LIBRARY_PATH=.*,export LD_LIBRARY_PATH=/usr/lib,g' Albion-Online
+ #sed -i 's,export QT_QPA_PLATFORM_PLUGIN_PATH=.*,export QT_QPA_PLATFORM_PLUGIN_PATH=/usr/lib/qt/plugins/platforms,g' Albion-Online
+ #sed -i 's,export QT_PLUGIN_PATH=.*,export QT_PLUGIN_PATH=/usr/lib/qt/plugins,g' Albion-Online
+ sed -i 's,.*launcher/Albion-Online",QT_AUTO_SCREEN_SCALE_FACTOR=0 LD_PRELOAD=/opt/albion-online-launcher-bin/game_x64/Albion-Online_Data/Plugins/x86_64/libSDL2-2.0.so.0 "$SCRIPTPATH/launcher/Albion-Online",g' Albion-Online
popd
}
@@ -32,18 +41,21 @@ package() {
mkdir -p "${pkgdir}/opt"
cp -a "${srcdir}/data" "${pkgdir}/opt/${pkgname}"
- mkdir ${pkgdir}/opt/${pkgname}/staging_x64
- chmod 777 ${pkgdir}/opt/${pkgname}/staging_x64
+ mkdir "${pkgdir}/opt/${pkgname}/staging_x64"
+ chmod 775 "${pkgdir}/opt/${pkgname}/staging_x64"
- mkdir ${pkgdir}/opt/${pkgname}/game_x64
- chmod 777 ${pkgdir}/opt/${pkgname}/game_x64
+ mkdir "${pkgdir}/opt/${pkgname}/game_x64"
+ chmod 775 "${pkgdir}/opt/${pkgname}/game_x64"
# link launcher launcher
- mkdir -p ${pkgdir}/usr/bin
+ mkdir -p "${pkgdir}/usr/bin"
ln -s "/opt/$pkgname/Albion-Online" "${pkgdir}/usr/bin/albion-online-launcher"
# install .desktop file
- install -m755 -D ${srcdir}/albion-online-launcher.desktop -t ${pkgdir}/usr/share/applications
+ install -m755 -D "${srcdir}/albion-online-launcher.desktop" -t "${pkgdir}/usr/share/applications"
+
+ # put the EULA somewhere
+ install -Dm644 "${srcdir}/data/eula.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim:set ts=2 sw=2 et:
diff --git a/albion-online-launcher-bin.install b/albion-online-launcher-bin.install
new file mode 100644
index 000000000000..904a84c3541e
--- /dev/null
+++ b/albion-online-launcher-bin.install
@@ -0,0 +1,14 @@
+post_install() {
+ post_upgrade
+}
+
+post_upgrade() {
+ groupadd -r albion &> /dev/null
+
+ cat << "EOM"
+==> If you'd like to allow the launcher to update the game client, add your user to the albion group
+EOM
+
+ chgrp -R albion "/opt/albion-online-launcher-bin/game_x64"
+ chgrp -R albion "/opt/albion-online-launcher-bin/staging_x64"
+}