summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeancahu2022-09-14 15:27:29 -0600
committerJeancahu2022-09-14 15:27:29 -0600
commite68be9cc47cdc1820e30980b3ae62f5ab873ac84 (patch)
treeac56dba026ccb4af936b64edd5c0adeb0a456d7a
parent70aeed32d04bbd02937f976ff62c1957f19c1def (diff)
downloadaur-e68be9cc47cdc1820e30980b3ae62f5ab873ac84.tar.gz
fix: no zenity when user==root
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD5
-rwxr-xr-xalbion-online8
3 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f622702fdf90..c05a9e140e51 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = albion-online-launcher-bin
pkgdesc = The first true cross-platform Sandbox MMO -- launcher client
pkgver = 1.20.060.231052
- pkgrel = 3
+ pkgrel = 4
url = https://albiononline.com/
install = albion-online-launcher-bin.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4a12a08253c6..758565260d34 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=albion-online-launcher-bin
pkgver=1.20.060.231052
-pkgrel=3
+pkgrel=4
pkgdesc="The first true cross-platform Sandbox MMO -- launcher client"
url="https://albiononline.com/"
arch=('x86_64')
@@ -42,7 +42,8 @@ prepare() {
libcrypto.so libssl.so libxkbcommon* libxcb*
rm -r resources plugins translations
- chmod 755 "./*"
+ chmod 775 "./*"
+ chmod 664 version.txt
popd
pushd "${srcdir}/data"
diff --git a/albion-online b/albion-online
index fd48599a7116..cbf5f922b0aa 100755
--- a/albion-online
+++ b/albion-online
@@ -4,13 +4,7 @@ declare no_group="Please run the next command in your terminal to give your user
declare no_sudo="Don't run this game as root(sudo)!! it could be a security risk!"
if [[ "$USER" == "root" ]]; then
- if zenity \
- --info \
- --text="$no_sudo"; then :
- else
- ## Zenity is not installed
- printf "${no_sudo}\n"
- fi
+ printf "${no_sudo}\n"
exit 1
fi