summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPu Anlai2021-07-09 15:41:13 +0200
committerPu Anlai2021-07-09 15:41:13 +0200
commit85e5833911a68077654bb405e508c8e9caf03ebf (patch)
tree87438d6b6fb2ce9dd2930c0020a91e91cd913fec
parent3f29a7b5d71294cf8a11d35e430ddf4255dfa9af (diff)
downloadaur-85e5833911a68077654bb405e508c8e9caf03ebf.tar.gz
Use poweriso instead of p7zip for image extraction
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4917aafb0de2..3c260909e727 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -8,8 +8,7 @@ pkgbase = albion-sr-gog
license = GPL
license = custom
makedepends = innoextract
- makedepends = bchunk
- makedepends = p7zip
+ makedepends = poweriso
makedepends = icoutils
depends = lib32-glibc
depends = lib32-sdl2_mixer
@@ -21,9 +20,8 @@ pkgbase = albion-sr-gog
source = setup_albion.exe::gog://setup_albion.exe
source = albion-sr-gog-1.7.1.tar.gz::https://github.com/M-HT/SR/releases/download/albion_v1.7.1/Albion-Linux-x86-v1.7.1-sdl2.tar.gz
source = albion.desktop
- sha1sums = SKIP
+ sha1sums = e716ed57e7957808ff66ad9da1c914f9cf6bfee8
sha1sums = 6ebfc6f8895eb2685698a24430495b585f09b2a3
sha1sums = b307af4b606f2510e1664ce96765cdc7f652bb06
pkgname = albion-sr-gog
-
diff --git a/PKGBUILD b/PKGBUILD
index 68ec03f22df5..6086621918e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,25 +8,25 @@
pkgname=albion-sr-gog
_pkgname=Albion-Linux
pkgver=1.7.1
-pkgrel=1
+pkgrel=2
pkgdesc="Linux port of the role-playing game Albion using the GOG version"
arch=("x86_64")
url="https://github.com/M-HT/SR"
license=("GPL" "custom")
depends=("lib32-glibc" "lib32-sdl2_mixer" "lib32-sdl2" "lib32-libpulse")
-makedepends=("innoextract" "bchunk" "p7zip" "icoutils")
+makedepends=("innoextract" "poweriso" "icoutils")
backup=("opt/ALBION/Albion.cfg")
install="albion-sr-gog.install"
source=("setup_albion.exe::gog://setup_albion.exe"
"${pkgname}-${pkgver}.tar.gz::https://github.com/M-HT/SR/releases/download/albion_v${pkgver}/${_pkgname}-x86-v${pkgver}-sdl2.tar.gz"
"albion.desktop")
+sha1sums=('e716ed57e7957808ff66ad9da1c914f9cf6bfee8'
+ '6ebfc6f8895eb2685698a24430495b585f09b2a3'
+ 'b307af4b606f2510e1664ce96765cdc7f652bb06')
noextract=("${pkgname}-${pkgver}.tar.gz"
"setup_albion.exe")
# don't download anything automatically to accomodate different language versions
DLAGENTS+=("gog::/usr/bin/perl -E print\(\"${RED}\"\ .\ substr\(\"%u\",\ 6\)\ .\ \"\ not\ found.\ \ Check\ the\ PKGBUILD\ for\ further\ information.${ALL_OFF}\\\\n\"\)\;\ exit\ 1")
-sha1sums=(SKIP
- '6ebfc6f8895eb2685698a24430495b585f09b2a3'
- 'b307af4b606f2510e1664ce96765cdc7f652bb06')
prepare() {
mkdir -p "${pkgname}-${pkgver}"
@@ -37,8 +37,7 @@ prepare() {
# get stuff from the bin image
mkdir -p $srcdir/gog-cd
- bchunk $srcdir/gog-src/game.gog $srcdir/gog-src/game.ins game
- 7z x -ogog-cd game*iso
+ poweriso extract $srcdir/gog-src/game.ins / -od $srcdir/gog-cd
# get icons
mkdir -p $srcdir/gog-icon