summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAshley Whetter2015-06-08 11:50:55 +0100
committerAshley Whetter2015-06-08 11:50:55 +0100
commiteca427e7959dd497009b87e3bd1e29f4b5666aa8 (patch)
tree75a80f22e9a4e36071b050c5ff8284e7c239daaa
downloadaur-eca427e7959dd497009b87e3bd1e29f4b5666aa8.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
-rw-r--r--albumart-coding.patch8
-rw-r--r--use_pillow.patch84
4 files changed, 156 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6549ecf2b66b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = albumart
+ pkgdesc = Semi-automatic downloader for album cover images for your music collection.
+ pkgver = 1.6.6
+ pkgrel = 3
+ url = http://www.unrealvoodoo.org/hiteck/projects/albumart/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = python2
+ depends = pyqt3
+ depends = python2-pillow
+ source = https://www.googledrive.com/host/0B3j8F3jHfinZOFFXLXdvYVZKNFU/albumart/albumart-1.6.6.tar.gz
+ source = albumart-coding.patch
+ source = use_pillow.patch
+ md5sums = 445a487eea4b8e41e85b47134edb330a
+ md5sums = 582a0584c6a27a33c00d4909988b3d0b
+ md5sums = SKIP
+
+pkgname = albumart
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c60070352612
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Ashley Whetter <(firstname) @ awhetter.co.uk>
+# Contributor: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=albumart
+pkgver=1.6.6
+pkgrel=3
+pkgdesc="Semi-automatic downloader for album cover images for your music collection."
+arch=('i686' 'x86_64')
+url="http://www.unrealvoodoo.org/hiteck/projects/albumart/"
+license=('GPL')
+depends=('python2' 'pyqt3' 'python2-pillow')
+source=("https://www.googledrive.com/host/0B3j8F3jHfinZOFFXLXdvYVZKNFU/albumart/albumart-1.6.6.tar.gz"
+ "$pkgname-coding.patch"
+ 'use_pillow.patch')
+
+md5sums=('445a487eea4b8e41e85b47134edb330a'
+ '582a0584c6a27a33c00d4909988b3d0b'
+ 'SKIP')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -Np1 -i $srcdir/use_pillow.patch
+ python2 setup.py build
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ python2 setup.py install --root=$pkgdir --prefix=/usr
+
+ cd $pkgdir
+ patch -Np1 -i $srcdir/$pkgname-coding.patch
+ sed "s/\#\!\/usr\/bin\/python/\#\!\/usr\/bin\/python2/" -i $pkgdir/usr/bin/albumart-qt
+
+ if [ -f /usr/bin/startkde ]; then
+ echo "Installing with KDE support"
+ install -d $pkgdir/opt/kde/share
+ mv $pkgdir/usr/share/{applnk,apps} $pkgdir/opt/kde/share
+ else
+ install -d $pkgdir/usr/share/applications/
+ mv $pkgdir/usr/share/applnk/Multimedia/albumart.desktop \
+ $pkgdir/usr/share/applications/
+ rm -rf $pkgdir/usr/share/{applnk,apps}
+ fi
+}
diff --git a/albumart-coding.patch b/albumart-coding.patch
new file mode 100644
index 000000000000..db23fbcbcf18
--- /dev/null
+++ b/albumart-coding.patch
@@ -0,0 +1,8 @@
+--- pkg/usr/lib/albumart/albumart_images.py.orig 2008-02-17 21:46:21.000000000 +0100
++++ pkg/usr/lib/albumart/albumart_images.py 2008-04-14 23:46:22.000000000 +0200
+@@ -1,4 +1,4 @@
+-# -*- coding: iso-8859-1 -*-
++# -*- coding: utf-8 -*-
+ # Image collection for project 'albumart'.
+ #
+ # Generated from reading image files:
diff --git a/use_pillow.patch b/use_pillow.patch
new file mode 100644
index 000000000000..904df92c689e
--- /dev/null
+++ b/use_pillow.patch
@@ -0,0 +1,84 @@
+diff -Nuar albumart-1.6.6.orig/lib/albumart/albumart_dialog.py albumart-1.6.6/lib/albumart/albumart_dialog.py
+--- albumart-1.6.6.orig/lib/albumart/albumart_dialog.py 2014-02-13 16:24:45.652259748 +0000
++++ albumart-1.6.6/lib/albumart/albumart_dialog.py 2014-02-13 23:34:37.442664371 +0000
+@@ -20,7 +20,7 @@
+ import time
+ import urllib
+ import tempfile
+-import Image
++from PIL import Image
+ import ConfigParser
+ import cPickle as pickle
+ import codecs
+diff -Nuar albumart-1.6.6.orig/lib/albumart/albumart_source_amazon.py albumart-1.6.6/lib/albumart/albumart_source_amazon.py
+--- albumart-1.6.6.orig/lib/albumart/albumart_source_amazon.py 2014-02-13 16:24:45.648926413 +0000
++++ albumart-1.6.6/lib/albumart/albumart_source_amazon.py 2014-02-13 23:34:37.439331037 +0000
+@@ -6,7 +6,7 @@
+ import amazon
+ import albumart
+ import tempfile
+-import Image
++from PIL import Image
+
+ defaultConfig = {
+ "enabled": 1,
+diff -Nuar albumart-1.6.6.orig/lib/albumart/albumart_target_freedesktop.py albumart-1.6.6/lib/albumart/albumart_target_freedesktop.py
+--- albumart-1.6.6.orig/lib/albumart/albumart_target_freedesktop.py 2014-02-13 16:24:45.652259748 +0000
++++ albumart-1.6.6/lib/albumart/albumart_target_freedesktop.py 2014-02-13 23:34:37.442664371 +0000
+@@ -3,7 +3,7 @@
+ """Save image in Freedesktop.org's desktop file standard (for KDE, GNOME, etc.)"""
+
+ import albumart
+-import Image
++from PIL import Image
+ import ConfigParser
+ import os
+
+diff -Nuar albumart-1.6.6.orig/lib/albumart/albumart_target_generic.py albumart-1.6.6/lib/albumart/albumart_target_generic.py
+--- albumart-1.6.6.orig/lib/albumart/albumart_target_generic.py 2014-02-13 16:24:45.648926413 +0000
++++ albumart-1.6.6/lib/albumart/albumart_target_generic.py 2014-02-13 23:34:37.439331037 +0000
+@@ -3,7 +3,7 @@
+ """Save the image to an arbitrary file."""
+
+ import albumart
+-import Image
++from PIL import Image
+ import os
+
+ scales = {
+diff -Nuar albumart-1.6.6.orig/lib/albumart/albumart_target_id3v2.py albumart-1.6.6/lib/albumart/albumart_target_id3v2.py
+--- albumart-1.6.6.orig/lib/albumart/albumart_target_id3v2.py 2014-02-13 16:24:45.648926413 +0000
++++ albumart-1.6.6/lib/albumart/albumart_target_id3v2.py 2014-02-13 23:34:37.439331037 +0000
+@@ -7,7 +7,7 @@
+ import os
+ import id3 # PyID3, see http://icepick.info/projects/pyid3/
+ import tempfile
+-import Image
++from PIL import Image
+
+ # all defined APIC picture types
+ pictureTypes = id3.ID3v2Frames.AttachedPicture.picturetypes
+diff -Nuar albumart-1.6.6.orig/lib/albumart/albumart_target_windows.py albumart-1.6.6/lib/albumart/albumart_target_windows.py
+--- albumart-1.6.6.orig/lib/albumart/albumart_target_windows.py 2014-02-13 16:24:45.648926413 +0000
++++ albumart-1.6.6/lib/albumart/albumart_target_windows.py 2014-02-13 23:34:37.439331037 +0000
+@@ -3,7 +3,7 @@
+ """Set image for Windows Media Player, Windows Explorer, etc."""
+
+ import albumart
+-import Image
++from PIL import Image
+ import os
+
+ scales = {
+diff -Nuar albumart-1.6.6.orig/lib/albumart/process.py albumart-1.6.6/lib/albumart/process.py
+--- albumart-1.6.6.orig/lib/albumart/process.py 2014-02-13 16:24:45.652259748 +0000
++++ albumart-1.6.6/lib/albumart/process.py 2014-02-13 23:34:37.442664371 +0000
+@@ -1,7 +1,7 @@
+ from qt import *
+ from event import *
+ import albumart
+-import Image
++from PIL import Image
+ import version
+ import traceback
+ import sys