summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenhat Hex2022-01-18 15:17:51 -0500
committerXenhat Hex2022-01-18 15:17:51 -0500
commitc968a3c357e0f73bc6db288e38a14747d36a277d (patch)
tree7610eb3d9b5e2d4253d6412788f507e79c019d5a
parent7d7163fecdceac9a9e50f1140b6340aa43827184 (diff)
downloadaur-c968a3c357e0f73bc6db288e38a14747d36a277d.tar.gz
Remove desktop file, use bundled scripts instead to generate it
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--alchemy-next.desktop11
-rw-r--r--alchemy.install8
4 files changed, 17 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a31dedaf255c..595dca785315 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -3,6 +3,7 @@ pkgbase = alchemy-next-viewer-bin
pkgver = 6.5.2.1342
pkgrel = 3
url = https://www.alchemyviewer.org
+ install = alchemy.install
arch = x86_64
license = LGPL
makedepends = sed
@@ -32,10 +33,7 @@ pkgbase = alchemy-next-viewer-bin
provides = alchemy-viewer
options = !strip
source = Alchemy_Project_AgileAkita_6_5_2_1342_x86_64.tar.bz2::https://git.alchemyviewer.org/api/v4/projects/78/packages/generic/Alchemy_Project_AgileAkita/6.5.2.1342/Alchemy_Project_AgileAkita_6_5_2_1342_x86_64.tar.bz2
- source = alchemy-next.desktop
sha1sums = 3479198ce34e8d6a52f88a8627e6ab16bc72fa81
- sha1sums = 8468775b4863b9a4d5c7c0f7d0319a54b97636de
b2sums = c78acbfb5015a4d36e4169f8624fd8711eda0d93f0fe89e37ea570633ae00d328208380a176b499ac3bcf547bd470190f7479eb31225b62f3e858e65551f8256
- b2sums = fbab51351cd1c427563fdaf8ffd35d1ca2aef3f4eaea03644cc35cd2063b0b3ea29fd96ca9cc774f21d6172584c195a79aafab4b37aa1108c9e47abef013f709
pkgname = alchemy-next-viewer-bin
diff --git a/PKGBUILD b/PKGBUILD
index f2e4160f76d8..dbc3618af82e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,7 @@ arch=('x86_64')
url=https://www.alchemyviewer.org
license=('LGPL')
options=(!strip)
+install=alchemy.install
# depends=(dbus-glib glu gtk3 lib32-libidn lib32-libsndfile lib32-util-linux lib32-zlib libgl libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl2 vlc zlib)
depends=(dbus-glib glu gtk3 libgl libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl2 vlc zlib)
makedepends=(sed)
@@ -27,21 +28,16 @@ optdepends=(
'nvidia-libgl: NVIDIA support'
'nvidia-utils: NVIDIA support')
provides=('alchemy-viewer')
-source=("${_pkgfolder}.tar.bz2"::'https://git.alchemyviewer.org/api/v4/projects/78/packages/generic/'"${_releasename_underscored}/${pkgver}/${_pkgfolder}.tar.bz2"
- 'alchemy-next.desktop')
-sha1sums=('3479198ce34e8d6a52f88a8627e6ab16bc72fa81'
- '8468775b4863b9a4d5c7c0f7d0319a54b97636de')
-b2sums=('c78acbfb5015a4d36e4169f8624fd8711eda0d93f0fe89e37ea570633ae00d328208380a176b499ac3bcf547bd470190f7479eb31225b62f3e858e65551f8256'
- 'fbab51351cd1c427563fdaf8ffd35d1ca2aef3f4eaea03644cc35cd2063b0b3ea29fd96ca9cc774f21d6172584c195a79aafab4b37aa1108c9e47abef013f709')
-pkgver() {
- echo "${pkgver}"
-}
+source=("${_pkgfolder}.tar.bz2"::'https://git.alchemyviewer.org/api/v4/projects/78/packages/generic/'"${_releasename_underscored}/${pkgver}/${_pkgfolder}.tar.bz2")
+sha1sums=('3479198ce34e8d6a52f88a8627e6ab16bc72fa81')
+b2sums=('c78acbfb5015a4d36e4169f8624fd8711eda0d93f0fe89e37ea570633ae00d328208380a176b499ac3bcf547bd470190f7479eb31225b62f3e858e65551f8256')
+# pkgver() {
+ # echo "${pkgver}"
+# }
package() {
mkdir -p "${pkgdir}"/opt
- mv "${srcdir}/${_pkgfolder}" "${pkgdir}/opt/${pkgname}"
- install -Dm644 "alchemy-next.desktop" "${pkgdir}/usr/local/share/applications/${pkgname}.desktop"
# Patch shortcut to avoid duplicated entries
- sed -i 's;Name=Alchemy;Name='"${_releasename}"';' "${pkgdir}/usr/local/share/applications/${pkgname}.desktop"
sed -i 's;Name=Alchemy;Name='"${_releasename}"';' "${pkgdir}/opt/${pkgname}/etc/refresh_desktop_app_entry.sh"
sed -i 's;alchemy-viewer\.desktop;'"${pkgname}"';' "${pkgdir}/opt/${pkgname}/etc/refresh_desktop_app_entry.sh"
+ mv "${srcdir}/${_pkgfolder}" "${pkgdir}/opt/${pkgname}"
}
diff --git a/alchemy-next.desktop b/alchemy-next.desktop
deleted file mode 100644
index 3c580dc56af2..000000000000
--- a/alchemy-next.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Name=Alchemy
-Comment=Client for the On-line Virtual World, Second Life
-Exec=/opt/alchemy-next-viewer-bin/etc/../alchemy
-Icon=/opt/alchemy-next-viewer-bin/etc/../alchemy_icon.png
-Terminal=false
-Type=Application
-Categories=Game;Simulation;
-StartupNotify=true
-StartupWMClass=Alchemy
-X-Desktop-File-Install-Version=3.0
diff --git a/alchemy.install b/alchemy.install
new file mode 100644
index 000000000000..b637cb15c03f
--- /dev/null
+++ b/alchemy.install
@@ -0,0 +1,8 @@
+#!/bin/bash
+post_install() {
+ bash /opt/alchemy-next-viewer-bin/etc/refresh_desktop_app_entry.sh "/opt/alchemy-next-viewer-bin" "/usr/local/share/applications/"
+ bash /opt/alchemy-next-viewer-bin/etc/register_secondlifeprotocol.sh
+}
+post_upgrade() {
+ post_install $1
+}