summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenHat2023-03-27 21:30:38 -0400
committerXenHat2023-03-27 21:30:38 -0400
commit015af61cf8d6fe80e933d8416dd9f3eb8d0e1d1d (patch)
tree84a5c2dc73ac32f4ccfa7f140e794113265e42a6
parent0acf5ae2ebf8245e42c31002e9ca85bc0e54dea0 (diff)
downloadaur-015af61cf8d6fe80e933d8416dd9f3eb8d0e1d1d.tar.gz
use march=native for git build to get best performance
-rwxr-xr-xPKGBUILD2
-rwxr-xr-xcompile.bash3
2 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95e8fad48568..a2402b2b2efd 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}"
'compile.bash')
sha256sums=('SKIP'
- '7bbe2e4f05163291937e02420dda210b7add59d689a7445c8c0c699b82570c22')
+ '7c841143956b312b2abb47d89151be9522e6fb0391450e311a3f4696aa05f792')
pkgver() {
cd "${pkgname}" || exit 1
diff --git a/compile.bash b/compile.bash
index 06e3cb903f5e..9a20852afa30 100755
--- a/compile.bash
+++ b/compile.bash
@@ -64,8 +64,7 @@ build() {
fi
fi
export AUTOBUILD_CPU_COUNT=$build_jobs
-
- AL_ARCH_FLAGS=${AL_ARCH_FLAGS:-'-march=x86-64-v2 -mtune=native -w'}
+ AL_ARCH_FLAGS=${AL_ARCH_FLAGS:-'-march=native -mtune=native -w'}
AL_CMAKE_CONFIG=(
-DLL_TESTS:BOOL=OFF
-DDISABLE_FATAL_WARNINGS=ON