summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenHat2023-05-09 21:54:39 -0400
committerXenHat2023-05-09 21:55:15 -0400
commit130065f92a559167a5ea5de090b0609e4b8b3431 (patch)
tree3d384823f49bfc9b570663b17ca52445c4c50f5c
parent0a632bae1154e694b70b087bac7780d5e079952f (diff)
downloadaur-130065f92a559167a5ea5de090b0609e4b8b3431.tar.gz
LTO is broken, do not use it.
Also disabled injecting build flags and additional binary stripping through makepkg
-rwxr-xr-xPKGBUILD7
-rwxr-xr-xcompile.bash2
2 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 706921ba0e46..f6382ccff85e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,10 +5,11 @@
#
# shellcheck disable=2034,3030,2154
pkgname=alchemy-next-viewer-git
-pkgver=6.11.50889.0d21c42e3c
-pkgrel=3
+pkgver=7.0.52754.344ee89df3
+pkgrel=1
pkgdesc="A Second Life client with focus on performance and code correctness. - Git Source build"
arch=('x86_64')
+options=('!buildflags' '!lto' '!strip')
url=https://www.alchemyviewer.org
license=('LGPL')
depends=(dbus-glib glu gtk3 libgl libiconv libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl2 vlc zlib)
@@ -32,7 +33,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}"
'compile.bash')
sha256sums=('SKIP'
- 'bf8affe4029053fd38b6b9408e695ed09dc8147b3e91dda08d0db6852829de88')
+ 'fbd63839b016543f8743577d6ab272cc2def20361c559b7fb21fac127356fe5b')
pkgver() {
cd "${pkgname}" || exit 1
diff --git a/compile.bash b/compile.bash
index ec597eccce57..a32fd0cbe9d0 100755
--- a/compile.bash
+++ b/compile.bash
@@ -91,7 +91,7 @@ build() {
AL_CMAKE_CONFIG=(
-DLL_TESTS:BOOL=ON
-DDISABLE_FATAL_WARNINGS=ON
- -DUSE_LTO:BOOL=ON
+ -DUSE_LTO:BOOL=OFF
-DVIEWER_CHANNEL="Alchemy Test"
)
# I could not find the documentation on how to handle BUILDENV/OPTION in