summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenhat Hex2023-05-22 19:22:49 -0400
committerXenhat Hex2023-05-22 19:22:49 -0400
commit1c2a7460e59ea56b50db28da6e854b1b2b337f57 (patch)
treecb69901a6899e79733dc8580a2734b4c8385b10b
parent914cf57f5027ed6be8a108bd65070beb567e970c (diff)
downloadaur-1c2a7460e59ea56b50db28da6e854b1b2b337f57.tar.gz
cleanup
-rwxr-xr-xPKGBUILD3
-rwxr-xr-xci.bash21
2 files changed, 2 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7147a006ba24..9ebafa890567 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ arch=('x86_64')
license=('LGPL')
options=('!buildflags' '!lto' '!strip')
url="https://www.alchemyviewer.org"
-depends=(dbus-glib glu gtk3 libgl libiconv libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl2 vlc xdg-desktop-portal zlib)
+depends=(glu libgl libiconv libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl2 vlc xdg-desktop-portal zlib)
makedepends=('gcc' 'python-virtualenv' 'python-pip' 'git' 'xz')
optdepends=(
'alsa-lib: ALSA support'
@@ -36,6 +36,7 @@ _distname="Alchemy-Config-Simple"
# template start; name=systemd-git; version=1.0;
_distdir="${_distname}-${pkgver}"
+depends+=(systemd-libs)
conflicts+=("alchemy-next-viewer-nosystemd-git")
pkgver() {
diff --git a/ci.bash b/ci.bash
deleted file mode 100755
index 63bea6407507..000000000000
--- a/ci.bash
+++ /dev/null
@@ -1,21 +0,0 @@
-#!/usr/bin/env bash
-#git clean -dfX
-SOURCE="${BASH_SOURCE[0]}"
-while [ -h "$SOURCE" ]; do # resolve $SOURCE until the file is no longer a symlink
- DIR="$( cd -P "$( dirname "$SOURCE" )" >/dev/null 2>&1 && pwd )"
- SOURCE="$(readlink "$SOURCE")"
- [[ $SOURCE != /* ]] && SOURCE="$DIR/$SOURCE" # if $SOURCE was a relative symlink, we need to resolve it relative to the path where the symlink file was located
-done
-DIR="$( cd -P "$( dirname "$SOURCE" )" >/dev/null 2>&1 && pwd )"
-cd "${DIR}" || return
-
-# Pull the aur repository first
-git reset --hard HEAD
-git pull
-
-# Weird pgrep fail with the complete binary name
-#if pgrep -a do-not-directly|grep alchemy ; then
-# echo "Aborting package build because Alchemy is running"
-# exit 0
-#fi
-makepkg --sync --needed --noconfirm