summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenhat Hex2022-09-23 16:51:13 -0400
committerXenhat Hex2022-09-23 16:51:13 -0400
commit34389ca4f76d680cbea002bade19424667e96514 (patch)
tree5e2904dfdff13258294a2bc9fd687f67ad0513d7
parentacc36eaf58141405673ce93ba58ce83d8e25dcf8 (diff)
downloadaur-34389ca4f76d680cbea002bade19424667e96514.tar.gz
fix missing variable. Build still broken.
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD5
-rwxr-xr-xcompile.bash14
3 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 83635cdcf05d..1f5c90b30add 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = alchemy-next-viewer-git
pkgdesc = This is the next generation of Alchemy Viewer! - Git Source build
- pkgver = 6.5.5.48678.e2a7db7b2e
+ pkgver = 6.5.5.48680.55fd3b5dda
pkgrel = 1
url = https://www.alchemyviewer.org
install = alchemy.install
@@ -48,6 +48,6 @@ pkgbase = alchemy-next-viewer-git
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
source = compile.bash
sha256sums = SKIP
- sha256sums = c9748e0c52156fef1cc8ba156d7056334332a0e75f305beabad571569b02698d
+ sha256sums = 7d6db14756c9051cedef54e02369e8f2944d89cf8ceb0cfae47dcde2698061d8
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 7ca70dadf765..56543228e851 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Xenhat Hex (aur@xenh.at)
# shellcheck disable=2034,3030,2154
pkgname=alchemy-next-viewer-git
-pkgver=6.5.5.48678.e2a7db7b2e
+pkgver=6.5.5.48680.55fd3b5dda
pkgrel=1
pkgdesc="This is the next generation of Alchemy Viewer! - Git Source build"
arch=('x86_64')
@@ -30,7 +30,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main'
'compile.bash')
sha256sums=('SKIP'
- 'c9748e0c52156fef1cc8ba156d7056334332a0e75f305beabad571569b02698d')
+ '7d6db14756c9051cedef54e02369e8f2944d89cf8ceb0cfae47dcde2698061d8')
pkgver() {
cd "${pkgname}" || exit 1
@@ -51,6 +51,7 @@ prepare() {
build() {
cd "${pkgname}" || exit 1
pwd
+ echo "PWD: $PWD"
../../compile.bash "${OPTIONS}"
}
diff --git a/compile.bash b/compile.bash
index 2275061867f5..28cf0d0b2be4 100755
--- a/compile.bash
+++ b/compile.bash
@@ -1,4 +1,5 @@
#!/usr/bin/env bash
+set -e
virtualenv ".venv" -p python3
source ".venv/bin/activate"
pip install --upgrade certifi
@@ -21,12 +22,6 @@ ulimit -n 20000
# -DDISABLE_FATAL_WARNINGS=ON \
# -DUSE_LTO:BOOL="$(grep -cq '[^!]lto' <<< "${1}" && echo 'ON' || echo 'OFF')" \
# -DVIEWER_CHANNEL="Alchemy Test"
-autobuild configure -A 64 -c ReleaseOS -- \
- -DLL_TESTS:BOOL=OFF \
- -DDISABLE_FATAL_WARNINGS=ON \
- -DUSE_LTO:BOOL=OFF \
- -DVIEWER_CHANNEL="Alchemy Test"
-cd "build-linux-64" || exit 1
jobcount=$(nproc)
if [[ ${jobcount} -gt 1 ]]; then
#if false; then
@@ -49,5 +44,12 @@ if [[ ${jobcount} -gt 1 ]]; then
jobcount=$((jobcount - 2))
fi
fi
+export AUTOBUILD_CPU_COUNT=$jobcount
echo "Building with ${jobcount} jobs (adjusted)"
+autobuild configure -A 64 -c ReleaseOS -- \
+ -DLL_TESTS:BOOL=OFF \
+ -DDISABLE_FATAL_WARNINGS=ON \
+ -DUSE_LTO:BOOL=OFF \
+ -DVIEWER_CHANNEL="Alchemy Test"
+cd "build-linux-64" || exit 1
time ninja -j${jobcount}