summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenHat2023-03-27 21:34:13 -0400
committerXenHat2023-03-27 21:34:13 -0400
commit34bf3ac0fddaa1ce9c9d4058e2df3cb617b93569 (patch)
treeb354ee6106e64fd5315dddb4da2570ad4c8ed61f
parenta0f769a34bd55cb766b9033926e1b6ac81294ebe (diff)
downloadaur-34bf3ac0fddaa1ce9c9d4058e2df3cb617b93569.tar.gz
Tentative fix for autobuild re-installing every build
-rwxr-xr-xPKGBUILD2
-rwxr-xr-xcompile.bash10
2 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bbbe74d85640..5ea90197d00c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -31,7 +31,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}"
'compile.bash')
sha256sums=('SKIP'
- 'b1804aa12f4ae454db93436b58a5cf2dfc8dfee191959e4209abfa2c6788980f')
+ 'c0e5802df3da9d3110974dd5469c65dd0a65c48b35d966b69e9c39d550a51a81')
pkgver() {
cd "${pkgname}" || exit 1
diff --git a/compile.bash b/compile.bash
index 510983f5482d..1888be9ec78d 100755
--- a/compile.bash
+++ b/compile.bash
@@ -16,13 +16,15 @@ prepare() {
if [[ -n "$USE_VENV" ]]; then
venv
fi
- echo "Installing autobuild..."
- pip install --upgrade certifi --quiet
- pip3 install --upgrade llbase --quiet
+
if command -v autobuild >/dev/null 2>&1 && [[ "$(autobuild --version)" == "autobuild 9.0.0" ]]; then
pip3 uninstall --yes autobuild --quiet
+ elif ! command -v autobuild; then
+ echo "Installing autobuild..."
+ pip3 install --upgrade certifi --quiet
+ pip3 install --upgrade llbase --quiet
+ pip3 install --no-cache --upgrade autobuild --quiet
fi
- pip3 install --no-cache --upgrade autobuild --quiet
}
build() {