summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenHat2023-01-18 18:00:21 -0500
committerXenHat2023-01-18 18:02:51 -0500
commit61a0fbceaa9b9515e6b02da3de582dd070130ac6 (patch)
treef262d1f1c936cb9128dddae5eb00f42d71601cd1
parent907f0cd4b18d16477a00a8f7ea2d734821145e53 (diff)
downloadaur-61a0fbceaa9b9515e6b02da3de582dd070130ac6.tar.gz
better ci fixes
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD2
-rwxr-xr-xci.bash6
-rwxr-xr-xcompile.bash13
4 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dca91975b09a..a33ecc49eaaa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -51,6 +51,6 @@ pkgbase = alchemy-next-viewer-git
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
source = compile.bash
sha256sums = SKIP
- sha256sums = b92fde75c1e327e4afd6bf756632f0a8769c7dc34050852f4361aca26fe6293f
+ sha256sums = 13c2f5015ec28e6ad344619376850f4db885ee460895ea28dbe11b99091fc5de
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index eeaf71f88186..8c19f0f1465d 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -63,4 +63,4 @@ package() {
mv "${pkgname}/build-linux-64/newview/packaged" "${pkgdir}/opt/${pkgname}"
}
sha256sums=('SKIP'
- 'b92fde75c1e327e4afd6bf756632f0a8769c7dc34050852f4361aca26fe6293f')
+ '13c2f5015ec28e6ad344619376850f4db885ee460895ea28dbe11b99091fc5de')
diff --git a/ci.bash b/ci.bash
index 8e424b51bfa4..dc6b77c4d8e6 100755
--- a/ci.bash
+++ b/ci.bash
@@ -9,12 +9,10 @@ done
DIR="$( cd -P "$( dirname "$SOURCE" )" >/dev/null 2>&1 && pwd )"
cd "${DIR}" || return
-git checkout .
-git reset --hard HEAD
-git pull
+git pull --prune
# Weird pgrep fail with the complete binary name
if pgrep -a do-not-directly|grep alchemy ; then
echo "Aborting package build because Alchemy is running"
exit 0
fi
-BUILDENV=(!distcc color !ccache check sign) makepkg --sync --install --noconfirm --needed
+BUILDENV=(!distcc color !ccache check) makepkg --cleanbuild --clean --sync --install --noconfirm --needed
diff --git a/compile.bash b/compile.bash
index c837e8eabbd9..0441e37c12e9 100755
--- a/compile.bash
+++ b/compile.bash
@@ -25,12 +25,6 @@ prepare() {
pip3 install --no-cache --upgrade autobuild --quiet
}
-cleanbuild()
-{
- rm -rf build-linux-64
- git pull --prune
- build()
-}
build() {
# we have a lot of files, relax ulimit to help performance
if [[ -n "$USE_VENV" ]]; then
@@ -93,6 +87,13 @@ build() {
echo "Building with ${AUTOBUILD_CPU_COUNT} jobs (adjusted)"
$prefix_cmd autobuild build -A64 -c ReleaseOS --no-configure
}
+
+cleanbuild()
+{
+ rm -rf build-linux-64
+ git pull --prune
+ build
+}
if [[ -n "$1" ]]; then
$1
else