summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenHat2022-12-23 15:24:59 -0500
committerXenHat2022-12-23 15:24:59 -0500
commit6a89dba57bc84471107abcb5d90943bd689a1b29 (patch)
tree10bc89be8f3fb9ff17db42260c3868714085f2b2
parent58ddebdec17026fd76d351a25e4bf978c76dc030 (diff)
downloadaur-6a89dba57bc84471107abcb5d90943bd689a1b29.tar.gz
update schedtool usage
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD4
-rwxr-xr-xcompile.bash5
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index feafea515551..ab555f15dd87 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alchemy-next-viewer-git
pkgdesc = This is the next generation of Alchemy Viewer! - Git Source build
pkgver = 6.6.9_r50289.gfeda3d3727
- pkgrel = 1
+ pkgrel = 2
url = https://www.alchemyviewer.org
install = alchemy.install
arch = x86_64
@@ -50,6 +50,6 @@ pkgbase = alchemy-next-viewer-git
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
source = compile.bash
sha256sums = SKIP
- sha256sums = 638758b69aeb0e145b2af29db7206453e0b6c0ee77c4c644f66bf4e6252fc285
+ sha256sums = 1575d64ab07e26189c757ce5556fe5be48eab19ca9a1b6677035cda6fb8da20b
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index f99de95399f1..bd8a2ee1f35b 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# shellcheck disable=2034,3030,2154
pkgname=alchemy-next-viewer-git
pkgver=6.6.9_r50289.gfeda3d3727
-pkgrel=1
+pkgrel=2
pkgdesc="This is the next generation of Alchemy Viewer! - Git Source build"
arch=('x86_64')
url=https://www.alchemyviewer.org
@@ -62,4 +62,4 @@ package() {
mv "${pkgname}/build-linux-64/newview/packaged" "${pkgdir}/opt/${pkgname}"
}
sha256sums=('SKIP'
- '638758b69aeb0e145b2af29db7206453e0b6c0ee77c4c644f66bf4e6252fc285')
+ '1575d64ab07e26189c757ce5556fe5be48eab19ca9a1b6677035cda6fb8da20b')
diff --git a/compile.bash b/compile.bash
index 08e8752febec..d04fddf6dc75 100755
--- a/compile.bash
+++ b/compile.bash
@@ -2,9 +2,10 @@
set -e
if command -v schedtool >/dev/null 2>&1; then
- prefix_cmd='schedtool -B -n1 -e'
+ # Set current shell and all descendents as SCHED_BATCH, see schedtool(8)
+ schedtool -B $$
+ prefix_cmd='schedtool -B -n20 -e '
fi
-prefix_cmd="${prefix_cmd} ionice -n 1"
venv() {
virtualenv ".venv" -p python3