summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenhat Hex2022-01-18 14:50:45 -0500
committerXenhat Hex2022-01-18 14:50:45 -0500
commit85f6901c79f5874e6c6af61b221fa2ce36e34ca3 (patch)
tree1ab34dd7feb698fc03af743a4eb5dabaeedbfc36
parentd65455d23d2f14d314e32bc617963b05ee02d3d2 (diff)
downloadaur-85f6901c79f5874e6c6af61b221fa2ce36e34ca3.tar.gz
cleanup ci.bash
-rwxr-xr-xci.bash11
1 files changed, 6 insertions, 5 deletions
diff --git a/ci.bash b/ci.bash
index 56f4db54df4e..43f6b423b8ae 100755
--- a/ci.bash
+++ b/ci.bash
@@ -1,6 +1,5 @@
#!/usr/bin/env bash
git clean -dfX
-unset AL_GIT_BRANCH
SOURCE="${BASH_SOURCE[0]}"
while [ -h "$SOURCE" ]; do # resolve $SOURCE until the file is no longer a symlink
DIR="$( cd -P "$( dirname "$SOURCE" )" >/dev/null 2>&1 && pwd )"
@@ -10,15 +9,17 @@ done
DIR="$( cd -P "$( dirname "$SOURCE" )" >/dev/null 2>&1 && pwd )"
cd "${DIR}" || return
-echo "stashing changes"
-#Stash any existing changes
-git stash
+# echo "stashing changes"
+# Stash any existing changes
+# git stash
+# git reset --hard HEAD
# pull and generate version as per PKGBUILD
echo "restarting clean configure..."
makepkg --sync --nobuild --cleanbuild
# makepkg --sync
echo "printing new info to files"
-makepkg -g
+updpkgsums
+# makepkg -g
makepkg --print > "${DIR}/.SRCINFO"
#if changes, commit and push
if git status --porcelain | grep -P '^\s*M'; then