summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenhat Hex2023-05-22 18:28:19 -0400
committerXenhat Hex2023-05-22 18:28:19 -0400
commit914cf57f5027ed6be8a108bd65070beb567e970c (patch)
treed628142cdea2680d6190541a72f45752b34df4f7
parentb1517f748956c688948b6d96e6baf7d0c62bcd28 (diff)
downloadaur-914cf57f5027ed6be8a108bd65070beb567e970c.tar.gz
New template-based PKGBUILD
-rw-r--r--.SRCINFO5
-rwxr-xr-xPKGBUILD118
-rwxr-xr-xcompile.bash127
3 files changed, 112 insertions, 138 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9c29e0b651fb..032dd62ec66f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alchemy-next-viewer-git
- pkgdesc = A Second Life client with focus on performance and code correctness. - Git Source build
pkgver = 6.11.50933.b7b3c99172
pkgrel = 2
+ pkgdesc = A Second Life client with focus on performance and code correctness.
url = https://www.alchemyviewer.org
install = alchemy.install
arch = x86_64
@@ -41,13 +41,12 @@ pkgbase = alchemy-next-viewer-git
optdepends = nvidia-utils: NVIDIA support
optdepends = wine: More up-to-date, less buggy SLVoice support
provides = alchemy-viewer
+ conflicts = alchemy-next-viewer-nosystemd-git
replaces = alchemy-viewer-git
options = !buildflags
options = !lto
options = !strip
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
- source = compile.bash
sha256sums = SKIP
- sha256sums = 20e5299ddbb96e46caf9ed211a912141c6a792f3a4aa7f82e56b1f98fe02c4fa
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 8bbdfed4f75f..7147a006ba24 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,11 @@
pkgname=alchemy-next-viewer-git
pkgver=6.11.50933.b7b3c99172
pkgrel=2
-pkgdesc="A Second Life client with focus on performance and code correctness. - Git Source build"
+pkgdesc="A Second Life client with focus on performance and code correctness."
arch=('x86_64')
+license=('LGPL')
options=('!buildflags' '!lto' '!strip')
url="https://www.alchemyviewer.org"
-license=('LGPL')
depends=(dbus-glib glu gtk3 libgl libiconv libidn libjpeg-turbo libpng libxss libxml2 mesa nss openal sdl2 vlc xdg-desktop-portal zlib)
makedepends=('gcc' 'python-virtualenv' 'python-pip' 'git' 'xz')
optdepends=(
@@ -29,10 +29,14 @@ optdepends=(
replaces=('alchemy-viewer-git')
provides=('alchemy-viewer')
install=alchemy.install
-source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}"
- 'compile.bash')
-sha256sums=('SKIP'
- '20e5299ddbb96e46caf9ed211a912141c6a792f3a4aa7f82e56b1f98fe02c4fa')
+source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch='"${AL_BRANCH_OVERRIDE:-main}")
+sha256sums=('SKIP')
+
+_distname="Alchemy-Config-Simple"
+
+# template start; name=systemd-git; version=1.0;
+_distdir="${_distname}-${pkgver}"
+conflicts+=("alchemy-next-viewer-nosystemd-git")
pkgver() {
cd "${pkgname}" || exit 1
@@ -48,13 +52,108 @@ pkgver() {
prepare() {
cd "${pkgname}" || exit 1
export USE_VENV=1
- ../compile.bash prepare
+# template start; name=prepare; version=1.0;
+if [[ -n "$USE_VENV" ]]; then
+ virtualenv ".venv" -p python3
+ . ".venv/bin/activate"
+fi
+
+echo "Installing build toolchain..."
+pip3 install --upgrade certifi --quiet
+pip3 install --upgrade llbase --quiet
+pip3 install --no-cache --upgrade autobuild --quiet
+pip3 install --upgrade cmake ninja
+
+# vi: set ai softtabstop=2 shiftwidth=2 tabstop=2 expandtab ft=sh :
+# template end;
}
build() {
cd "${pkgname}" || exit 1
export USE_VENV=1
- ../compile.bash build
+# template start; name=build; version=1.0;
+if command -v schedtool >/dev/null 2>&1; then
+ # Set current shell and all descendents as SCHED_BATCH, see schedtool(8)
+ schedtool -B $$
+ prefix_cmd='schedtool -B -n20 -e '
+fi
+ if [[ -n "$USE_VENV" ]]; then
+ . ".venv/bin/activate"
+ fi
+ build_jobs=$(nproc)
+ if [[ -z "$NO_SMART_JOB_COUNT" ]]; then
+ if [[ ${build_jobs} -gt 1 ]]; then
+ jobs=1
+ # The viewer requires an average of 2GB of memory per core to link
+ # Note: Behaviour change compared to the previous versions:
+ # This script will no longer try to allocate build memory into swap
+ # This is bad practice, and swap should be reserved to evict process
+ # memory from physical ram to make place for the current workset.
+ # This script will now try to check if swap is present and sufficent
+ # for the current used memory to be stored in swap before allocating,
+ # and will fallback to conservative allocation if swap is not available
+ gigperlinkprocess=2
+ mempercorekb=$((gigperlinkprocess * 1048576))
+ requiredmemorykb=$(($(nproc) * mempercorekb))
+ free_output="$(free --kilo --total | tail -n+2 | tr -s ' ')"
+ physical_output=$(grep "Mem:" <<<"$free_output")
+ #total_output=$(grep Total: <<< "$free_output")
+ usedmemorykbphysical=$(cut -d ' ' -f 3 <<<"$physical_output")
+ totalmemorykbphysical=$(cut -d ' ' -f 2 <<<"$physical_output")
+ swap_output=$(grep Swap: <<<"$free_output")
+ # Determine available swap space
+ availableswapkb=0
+ if [[ -n "$swap_output" ]]; then
+ availableswapkb=$(cut -d ' ' -f 4 <<<"$swap_output")
+ fi
+ availablememorykbphysical=$(cut -d ' ' -f 7 <<<"$free_output")
+ echo "Total memory: $totalmemorykbphysical (includes swap)"
+ echo "Available memory: $availablememorykbphysical"
+ echo "Required memory: $requiredmemorykb"
+ echo "Available physical memory on this system: $((availablememorykbphysical / 1024 / 1024)) GB"
+ echo "Estimated required memory to build with all cores: $((requiredmemorykb / 1024 / 1024)) GB"
+ if [[ ${requiredmemorykb} -gt ${availablememorykbphysical} ]]; then
+ echo "Warning: Not enough available physical memory to build with all cores"
+ if [[ ${usedmemorykbphysical} -lt ${availableswapkb} ]]; then
+ # use all physical ram as swap will do its job
+ echo "There is enough free swap to store the currently used memory"
+ jobs=$(((totalmemorykbphysical / 1024 / 1024) / gigperlinkprocess))
+ else
+ # Not enough swap to hold ram contents, calculate manually
+ echo "Allocating build jobs according to available physical memory ("$((availablememorykbphysical / 1024 / 1024))"/"$((requiredmemorykb / 1024 / 1024))"GB)..."
+ # FIXME: Goes one iteration beyond what it should
+ while [[ $((jobs * mempercorekb)) -lt ${availablememorykbphysical} ]]; do
+ jobs=$((jobs + 1))
+ echo -e "${jobs} jobs would consume $(((jobs * mempercorekb) / 1024 / 1024))GB"
+ done
+ # Back off one job count. Not sure why I have to do this but
+ # the loop is doing one extra iteration.
+ jobs=$((jobs - 1))
+ fi
+ build_jobs=${jobs}
+ echo "Computed job count: ${build_jobs}"
+ fi
+ fi
+ fi
+ export AUTOBUILD_CPU_COUNT=$build_jobs
+ AL_CMAKE_CONFIG=(
+ -DLL_TESTS:BOOL=ON
+ -DDISABLE_FATAL_WARNINGS=ON
+ -DUSE_LTO:BOOL=OFF
+ -DVIEWER_CHANNEL="Alchemy Test"
+ )
+ echo "BUILDENV: ${BUILDENV[*]}"
+ if [[ " ${BUILDENV[*]} " =~ ' ccache ' ]] && command -v ccache; then
+ echo "------ Will Use CCACHE ------"
+ CMAKE_CXX_COMPILER_LAUNCHER="$(which ccache)"
+ export CMAKE_CXX_COMPILER_LAUNCHER
+ fi
+ $prefix_cmd autobuild configure -A 64 -c ReleaseOS -- "${AL_CMAKE_CONFIG[@]}"
+ echo "Building with ${AUTOBUILD_CPU_COUNT} jobs (adjusted)"
+ $prefix_cmd autobuild build -A64 -c ReleaseOS --no-configure
+
+# vi: set ai softtabstop=2 shiftwidth=2 tabstop=2 expandtab ft=sh :
+# template end;
}
package() {
@@ -65,3 +164,6 @@ package() {
sed -i 's;alchemy-viewer\.desktop;'"${pkgname}\.desktop"';' "${pkgname}/build-linux-64/newview/packaged/etc/refresh_desktop_app_entry.sh"
mv "${pkgname}/build-linux-64/newview/packaged" "${pkgdir}/opt/${pkgname}"
}
+# vi: set ai softtabstop=2 shiftwidth=2 tabstop=2 expandtab ft=bash :
+
+# template end;
diff --git a/compile.bash b/compile.bash
deleted file mode 100755
index 8817494fcd2e..000000000000
--- a/compile.bash
+++ /dev/null
@@ -1,127 +0,0 @@
-#!/usr/bin/env bash
-set -e
-
-if command -v schedtool >/dev/null 2>&1; then
- # Set current shell and all descendents as SCHED_BATCH, see schedtool(8)
- schedtool -B $$
- prefix_cmd='schedtool -B -n20 -e '
-fi
-
-venv() {
- virtualenv ".venv" -p python3
- . ".venv/bin/activate"
-}
-
-prepare() {
- if [[ -n "$USE_VENV" ]]; then
- venv
- fi
-
- echo "Installing build toolchain..."
- pip3 install --upgrade certifi --quiet
- pip3 install --upgrade llbase --quiet
- pip3 install --no-cache --upgrade autobuild --quiet
- pip3 install --upgrade cmake ninja
-}
-
-build() {
- # we have a lot of files, relax ulimit to help performance
- if [[ -n "$USE_VENV" ]]; then
- . ".venv/bin/activate"
- fi
- set +e
- ulimit -n 20000
- set -e
- build_jobs=$(nproc)
- if [[ -z "$NO_SMART_JOB_COUNT" ]]; then
- if [[ ${build_jobs} -gt 1 ]]; then
- jobs=1
- # The viewer requires an average of 2GB of memory per core to link
- # Note: Behaviour change compared to the previous versions:
- # This script will no longer try to allocate build memory into swap
- # This is bad practice, and swap should be reserved to evict process
- # memory from physical ram to make place for the current workset.
- # This script will now try to check if swap is present and sufficent
- # for the current used memory to be stored in swap before allocating,
- # and will fallback to conservative allocation if swap is not available
- gigperlinkprocess=2
- mempercorekb=$((gigperlinkprocess * 1048576))
- requiredmemorykb=$(($(nproc) * mempercorekb))
- free_output="$(free --kilo --total | tail -n+2 | tr -s ' ')"
- physical_output=$(grep "Mem:" <<<"$free_output")
- #total_output=$(grep Total: <<< "$free_output")
- usedmemorykbphysical=$(cut -d ' ' -f 3 <<<"$physical_output")
- totalmemorykbphysical=$(cut -d ' ' -f 2 <<<"$physical_output")
- swap_output=$(grep Swap: <<<"$free_output")
- # Determine available swap space
- availableswapkb=0
- if [[ -n "$swap_output" ]]; then
- availableswapkb=$(cut -d ' ' -f 4 <<<"$swap_output")
- fi
- availablememorykbphysical=$(cut -d ' ' -f 7 <<<"$free_output")
- echo "Total memory: $totalmemorykbphysical (includes swap)"
- echo "Available memory: $availablememorykbphysical"
- echo "Required memory: $requiredmemorykb"
- echo "Available physical memory on this system: $((availablememorykbphysical / 1024 / 1024)) GB"
- echo "Estimated required memory to build with all cores: $((requiredmemorykb / 1024 / 1024)) GB"
- if [[ ${requiredmemorykb} -gt ${availablememorykbphysical} ]]; then
- echo "Warning: Not enough available physical memory to build with all cores"
- if [[ ${usedmemorykbphysical} -lt ${availableswapkb} ]]; then
- # use all physical ram as swap will do its job
- echo "There is enough free swap to store the currently used memory"
- jobs=$(((totalmemorykbphysical / 1024 / 1024) / gigperlinkprocess))
- else
- # Not enough swap to hold ram contents, calculate manually
- echo "Allocating build jobs according to available physical memory ("$((availablememorykbphysical / 1024 / 1024))"/"$((requiredmemorykb / 1024 / 1024))"GB)..."
- # FIXME: Goes one iteration beyond what it should
- while [[ $((jobs * mempercorekb)) -lt ${availablememorykbphysical} ]]; do
- jobs=$((jobs + 1))
- echo -e "${jobs} jobs would consume $(((jobs * mempercorekb) / 1024 / 1024))GB"
- done
- # Back off one job count. Not sure why I have to do this but
- # the loop is doing one extra iteration.
- jobs=$((jobs - 1))
- fi
- build_jobs=${jobs}
- echo "Computed job count: ${build_jobs}"
- fi
- fi
- fi
- export AUTOBUILD_CPU_COUNT=$build_jobs
- AL_CMAKE_CONFIG=(
- -DLL_TESTS:BOOL=ON
- -DDISABLE_FATAL_WARNINGS=ON
- -DUSE_LTO:BOOL=OFF
- -DVIEWER_CHANNEL="Alchemy Test"
- )
- # I could not find the documentation on how to handle BUILDENV/OPTION in
- # makepkg.conf. If you are reading this and know where it is,
- # please send it my way.
- # if [[ -n "$AL_NO_CCACHE" ]] || ! command -v ccache 2 > /dev/null 2>&1; then
- # echo "ccache disabled"
- # AL_CMAKE_CONFIG+=(-UCMAKE_CXX_COMPILER_LAUNCHER)
- # else
- # echo "ccache available and enabled"
- # export CCACHE_SLOPPINESS="file_macro,locale,time_macros"
- # export CCACHE_NOHASHDIR="true"
- # AL_CMAKE_CONFIG+=(-DCMAKE_CXX_COMPILER_LAUNCHER=ccache)
- # fi
- $prefix_cmd autobuild configure -A 64 -c ReleaseOS -- "${AL_CMAKE_CONFIG[@]}"
- echo "Building with ${AUTOBUILD_CPU_COUNT} jobs (adjusted)"
- $prefix_cmd autobuild build -A64 -c ReleaseOS --no-configure
-}
-
-cleanbuild() {
- rm -rf build-linux-64
- git pull --prune
- build
-}
-if [[ -n "$1" ]]; then
- $1
-else
- echo "Running unattended batch build..."
- prepare
- build
-fi
-
-# vi: set ai softtabstop=2 shiftwidth=2 tabstop=2 expandtab: