summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenhat Hex2022-09-30 18:08:36 -0400
committerXenhat Hex2022-09-30 18:08:36 -0400
commit947cb64db342514049ff4ac3c7f521652b9df657 (patch)
tree81b3be5ff4c1ce26170dc130e64ebb1bb99de264
parentf4f90a5a2fcf9b708a7c48ac7e200cc24d162f0c (diff)
downloadaur-947cb64db342514049ff4ac3c7f521652b9df657.tar.gz
update toolchain to new autobuild
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD6
-rwxr-xr-xcompile.bash13
3 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be7028ad3e68..7a84a0179260 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -48,6 +48,6 @@ pkgbase = alchemy-next-viewer-git
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
source = compile.bash
sha256sums = SKIP
- sha256sums = a97002b22640b2ee67019ed1c729dfb163116cdeeb4933755d6829e6fb02b82b
+ sha256sums = 6f9d1ea8262eed2fbf3bbdc6097e219e3880005a5e7e523596b080b8ef63e926
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 6732fa6afb4c..92807865ca7e 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Maintainer: Xenhat Hex (aur@xenh.at)
# shellcheck disable=2034,3030,2154
pkgname=alchemy-next-viewer-git
-pkgver=6.5.5.48680.55fd3b5dda
-pkgrel=2
+pkgver=6.5.5.48681.12c2a9b7e9
+pkgrel=1
pkgdesc="This is the next generation of Alchemy Viewer! - Git Source build"
arch=('x86_64')
url=https://www.alchemyviewer.org
@@ -30,7 +30,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main'
'compile.bash')
sha256sums=('SKIP'
- 'a97002b22640b2ee67019ed1c729dfb163116cdeeb4933755d6829e6fb02b82b')
+ '77693b95c77cde618a7f8d60087f8fb97d7db862a97eb5885a8c845c33b1e5e2')
pkgver() {
cd "${pkgname}" || exit 1
diff --git a/compile.bash b/compile.bash
index cad628deb7ca..b5cda332d269 100755
--- a/compile.bash
+++ b/compile.bash
@@ -4,9 +4,11 @@ virtualenv ".venv" -p python3
. ".venv/bin/activate"
pip install --upgrade certifi
pip3 install --upgrade llbase
-pip3 install --no-cache-dir --upgrade autobuild -i \
- https://git.alchemyviewer.org/api/v4/projects/54/packages/pypi/simple \
- --extra-index-url https://pypi.org/simple
+if $(command -v autobuild >/dev/null 2>&1) && [[ "$(autobuild --version)" == "autobuild 9.0.0" ]]; then
+ pip3 uninstall --yes autobuild
+fi
+pip3 install --no-cache --upgrade autobuild
+
# we have a lot of files, relax ulimit to help performance
ulimit -n 20000
AUTOBUILD_CPU_COUNT=$(nproc)
@@ -39,4 +41,7 @@ autobuild configure -A 64 -c ReleaseOS -- \
-DVIEWER_CHANNEL="Alchemy Test"
echo "Building with ${AUTOBUILD_CPU_COUNT} jobs (adjusted)"
-autobuild build -A64 -c ReleaseOS --no-configure \ No newline at end of file
+# job count is not overrideable...
+#autobuild build -A64 -c ReleaseOS --no-configure
+cd build-linux-64
+ninja -j${AUTOBUILD_CPU_COUNT}