summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenhat Hex2022-08-09 10:42:06 -0400
committerXenhat Hex2022-08-09 10:42:06 -0400
commita18983c6c8b3db2c1022451fd21dca873d930b18 (patch)
treeacfecedb88648bdf49d6f94f545cae3950ffc8ca
parent826f651c56f24a5df139967797413ff98139acc0 (diff)
downloadaur-a18983c6c8b3db2c1022451fd21dca873d930b18.tar.gz
add build script in PKGBUILD
-rw-r--r--.SRCINFO4
-rwxr-xr-xPKGBUILD8
2 files changed, 6 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 17636d61128e..3508171abb59 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -46,8 +46,8 @@ pkgbase = alchemy-next-viewer-git
options = !strip
options = !lto
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
- md5sums = SKIP
+ source = build_linux64.bash
sha256sums = SKIP
- b2sums = SKIP
+ sha256sums = c9748e0c52156fef1cc8ba156d7056334332a0e75f305beabad571569b02698d
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 63cb8879ed20..9ae90366e2c5 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,10 +27,8 @@ optdepends=(
provides=('alchemy-viewer')
options=(!emptydirs !makeflags !strip !lto)
install=alchemy.install
-source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main')
-md5sums=('SKIP')
-sha256sums=('SKIP')
-b2sums=('SKIP')
+source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main'
+'build_linux64.bash')
pkgver() {
cd "${pkgname}" || exit 1
@@ -62,3 +60,5 @@ package() {
sed -i 's;alchemy-viewer\.desktop;'"${pkgname}\.desktop"';' "${pkgname}/build-linux-64/newview/packaged/etc/refresh_desktop_app_entry.sh"
mv "${pkgname}/build-linux-64/newview/packaged" "${pkgdir}/opt/${pkgname}"
}
+sha256sums=('SKIP'
+ 'c9748e0c52156fef1cc8ba156d7056334332a0e75f305beabad571569b02698d')