summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXenhat Hex2022-09-25 14:25:36 -0400
committerXenhat Hex2022-09-25 14:25:36 -0400
commitf4f90a5a2fcf9b708a7c48ac7e200cc24d162f0c (patch)
tree548cf902d8ebd6073fe01f1267c0495f1ab0e338
parentbe92c2aae7fac94e479da618d48e260b6a35c2aa (diff)
downloadaur-f4f90a5a2fcf9b708a7c48ac7e200cc24d162f0c.tar.gz
cleanup
-rw-r--r--.SRCINFO2
-rwxr-xr-xPKGBUILD2
-rwxr-xr-xcompile.bash23
3 files changed, 6 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b3ffd4de714..be7028ad3e68 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -48,6 +48,6 @@ pkgbase = alchemy-next-viewer-git
source = alchemy-next-viewer-git::git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main
source = compile.bash
sha256sums = SKIP
- sha256sums = 7cdf3fd50b3bc3c2a85d5f6e78f40d28b9ae2888cca29202503891fab5e5da55
+ sha256sums = a97002b22640b2ee67019ed1c729dfb163116cdeeb4933755d6829e6fb02b82b
pkgname = alchemy-next-viewer-git
diff --git a/PKGBUILD b/PKGBUILD
index 11ffc9ecfa57..6732fa6afb4c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,7 +30,7 @@ install=alchemy.install
source=("${pkgname}"::'git+https://git.alchemyviewer.org/alchemy/alchemy-next.git#branch=main'
'compile.bash')
sha256sums=('SKIP'
- '7cdf3fd50b3bc3c2a85d5f6e78f40d28b9ae2888cca29202503891fab5e5da55')
+ 'a97002b22640b2ee67019ed1c729dfb163116cdeeb4933755d6829e6fb02b82b')
pkgver() {
cd "${pkgname}" || exit 1
diff --git a/compile.bash b/compile.bash
index 8cdebc0a1768..cad628deb7ca 100755
--- a/compile.bash
+++ b/compile.bash
@@ -1,29 +1,14 @@
#!/usr/bin/env bash
set -e
-# workaround for broken venv/autobuild
virtualenv ".venv" -p python3
. ".venv/bin/activate"
pip install --upgrade certifi
-#if command -v autobuild && \
-# [ "$(autobuild --version | cut -d ' ' -f 2 | tr -d '.')" -gt 210 ]
-#then
-# echo "Found Autobuild"
-#else
- pip3 install --upgrade llbase
- # pip3 uninstall autobuild --yes
- pip3 install --no-cache-dir --upgrade autobuild -i \
- https://git.alchemyviewer.org/api/v4/projects/54/packages/pypi/simple \
- --extra-index-url https://pypi.org/simple
-#fi
+pip3 install --upgrade llbase
+pip3 install --no-cache-dir --upgrade autobuild -i \
+ https://git.alchemyviewer.org/api/v4/projects/54/packages/pypi/simple \
+ --extra-index-url https://pypi.org/simple
# we have a lot of files, relax ulimit to help performance
ulimit -n 20000
-# shellcheck disable=SC2153
-# LTO is currently very broken for alchemy
-#autobuild configure -A 64 -c ReleaseOS -- \
-# -DLL_TESTS:BOOL=OFF \
-# -DDISABLE_FATAL_WARNINGS=ON \
-# -DUSE_LTO:BOOL="$(grep -cq '[^!]lto' <<< "${1}" && echo 'ON' || echo 'OFF')" \
-# -DVIEWER_CHANNEL="Alchemy Test"
AUTOBUILD_CPU_COUNT=$(nproc)
if [[ ${AUTOBUILD_CPU_COUNT} -gt 1 ]]; then
#if false; then