summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2016-10-16 23:15:16 +0200
committerbartus2016-10-16 23:15:16 +0200
commit6a11b72b93d2914ece360d7f536df1eb2b70c154 (patch)
tree95f03ed1b3d60fe7265fee5e0739c72e5fcdd1b5
downloadaur-6a11b72b93d2914ece360d7f536df1eb2b70c154.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD48
-rw-r--r--alchemy.desktop8
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c9258420d68f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = alchemy-svn
+ pkgdesc = Nonorthodox painting software exploring and experimenting with alternative ways of drawing
+ pkgver = r574
+ pkgrel = 1
+ url = http://al.chemy.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = apache-ant
+ depends = sh
+ depends = java-environment
+ depends = hicolor-icon-theme
+ source = alchemy-svn::svn+http://svn.al.chemy.org/svn/
+ source = alchemy.desktop
+ md5sums = SKIP
+ md5sums = c7cffede4dda0acd94aa94deec037720
+
+pkgname = alchemy-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7bcdc5144654
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Your Name <Alchemy-aur@bartus.33mail.com>
+pkgname=alchemy-svn
+pkgver=r574
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Nonorthodox painting software exploring and experimenting with alternative ways of drawing"
+url="http://al.chemy.org/"
+license=('GPL')
+depends=('sh' 'java-environment' 'hicolor-icon-theme')
+makedepends=('apache-ant')
+md5sums=('SKIP'
+ 'c7cffede4dda0acd94aa94deec037720')
+source=("${pkgname}::svn+http://svn.al.chemy.org/svn/"
+ "alchemy.desktop"
+ )
+
+pkgver() {
+ cd ${pkgname}
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd ${pkgname}/Alchemy
+ ant
+}
+
+package() {
+ cd ${pkgname}/Alchemy/
+ chmod -R o+r dist/*
+ install -dm755 ${pkgdir}/opt/alchemy
+ cp -r -t ${pkgdir}/opt/alchemy dist/Alchemy/*
+ install -dm755 ${pkgdir}/usr/bin
+ echo -e "#!/bin/sh\nexec /opt/alchemy/Alchemy" > ${pkgdir}/usr/bin/alchemy
+ echo -e "#!/bin/sh\nexec /opt/alchemy/AlchemyOpenGL" > ${pkgdir}/usr/bin/alchemy-opengl
+ chmod +x ${pkgdir}/usr/bin/*
+ install -dm755 ${pkgdir}/usr/share/doc/alchemy
+ cp -r -t ${pkgdir}/usr/share/doc/alchemy dist/javadoc/*
+ convert res/Alchemy.ico alchemy.png
+ install -Dm644 "alchemy-0.png" "${pkgdir}/usr/share/icons/hicolor/apps/256x256/alchemy.png"
+ install -Dm644 "alchemy-0.png" "${pkgdir}/usr/share/pixmaps/alchemy.png"
+ install -Dm644 "alchemy-1.png" "${pkgdir}/usr/share/icons/hicolor/apps/128x128/alchemy.png"
+ install -Dm644 "alchemy-2.png" "${pkgdir}/usr/share/icons/hicolor/apps/48x48/alchemy.png"
+ install -Dm644 "alchemy-3.png" "${pkgdir}/usr/share/icons/hicolor/apps/32x32/alchemy.png"
+ install -Dm644 "alchemy-4.png" "${pkgdir}/usr/share/icons/hicolor/apps/24x24/alchemy.png"
+ install -Dm644 "alchemy-5.png" "${pkgdir}/usr/share/icons/hicolor/apps/16x16/alchemy.png"
+ install -Dm644 "../../alchemy.desktop" "${pkgdir}/usr/share/applications/alchemy.desktop"
+}
diff --git a/alchemy.desktop b/alchemy.desktop
new file mode 100644
index 000000000000..fe63dc4de563
--- /dev/null
+++ b/alchemy.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Alchemy
+Comment="Program for nonarthodox painting expriments exploring alternative ways of drawing"
+Icon=alchemy
+Exec=alchemy
+Terminal=false
+Type=Application
+Categories=Graphics;