summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x715C2019-04-12 17:54:28 +1000
committer0x715C2019-04-12 18:03:41 +1000
commitdc224712f8a13f5643ecbecce7d3e4a31d03b6ce (patch)
tree02f300f9bf0a29be17b16d901ad2b2b38bca026b
downloadaur-dc224712f8a13f5643ecbecce7d3e4a31d03b6ce.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc3e1e6816e5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = alda-bin
+ pkgdesc = A music programming language for musicians.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://github.com/alda-lang/alda
+ arch = x86_64
+ license = EPL
+ provides = alda
+ conflicts = alda
+ noextract = alda
+ options = !strip
+ source = https://github.com/alda-lang/alda/releases/download/1.2.0/alda
+ sha256sums = 9c24d2c5791674cac3bd8b40ff67b17a132713a5d1c32d5e3e944a988e24f142
+
+pkgname = alda-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..836fb4e6f37b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: 0x715C <https://www.t.me/hex715C>
+
+pkgname=alda-bin
+_pkgname=alda
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='A music programming language for musicians. 🎶'
+arch=('x86_64')
+url='https://github.com/alda-lang/alda'
+license=('EPL')
+provides=('alda')
+conflicts=('alda')
+options=('!strip')
+source=("https://github.com/$_pkgname-lang/$_pkgname/releases/download/$pkgver/$_pkgname")
+sha256sums=('9c24d2c5791674cac3bd8b40ff67b17a132713a5d1c32d5e3e944a988e24f142')
+noextract=('alda')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 alda \
+ "${pkgdir}/usr/bin/${_pkgname}"
+}