summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x715C2021-07-14 02:45:47 +1000
committer0x715C2021-07-14 02:45:47 +1000
commit4ae00c522aaba2b6d47c481b2ac504d23bf67055 (patch)
treed547eb074c74ef415f83cf884cf0277ba5668804
parentd69cb532e03fc39fd6c0b6ad1568d5f13d76a5cc (diff)
downloadaur-4ae00c522aaba2b6d47c481b2ac504d23bf67055.tar.gz
Update to 2.0!
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD41
2 files changed, 34 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f2ad71fc828f..2ed4df67575a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,20 @@
pkgbase = alda-git
- pkgdesc = A music programming language for musicians.
- pkgver = 1.2.0.r17.g2203edf
+ pkgdesc = A music programming language for musicians. 🎶
+ pkgver = 2.0.1.r4.g2b1cb38
pkgrel = 1
url = https://github.com/alda-lang/alda
arch = x86_64
license = EPL
- makedepends = boot
- makedepends = launch4j
+ makedepends = fakeroot
+ makedepends = binutils
+ makedepends = git
+ makedepends = go
+ makedepends = java-environment>=8
+ depends = java-environment>=8
provides = alda
conflicts = alda
- options = docs
- options = !strip
- options = debug
- source = git://github.com/alda-lang/alda
- sha1sums = SKIP
+ source = git+https://github.com/alda-lang/alda
+ sha256sums = SKIP
pkgname = alda-git
diff --git a/PKGBUILD b/PKGBUILD
index 2f4f86c8281b..31adb9417015 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: 0x715C <https://www.t.me/hex715C>
+# Maintainer: 0x715C
pkgname=alda-git
_pkgname=alda
-pkgver=1.2.0.r17.g2203edf
+pkgver=2.0.1.r4.g2b1cb38
pkgrel=1
pkgdesc='A music programming language for musicians. 🎶'
arch=('x86_64')
@@ -10,31 +10,38 @@ url='https://github.com/alda-lang/alda'
license=('EPL')
provides=('alda')
conflicts=('alda')
-#depends=('boot')
-makedepends=('boot' 'launch4j')
-#optdepends=()
-options=('docs' '!strip' 'debug')
-source=('git://github.com/alda-lang/alda')
-sha1sums=('SKIP')
+depends=('java-environment>=8')
+makedepends=('fakeroot' 'binutils' 'git' 'go' 'java-environment>=8')
+source=('git+https://github.com/alda-lang/alda')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd "$srcdir/$_pkgname"
- mkdir -p bin
- sed -e 's/(exe :file file :output-dir output-dir)//g' -i build.boot
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/release.//'
}
build() {
- cd "$srcdir/$_pkgname"
- boot build -o bin/
+ #Build alda client
+ cd "$srcdir/$_pkgname/client"
+ go generate
+ go build -trimpath -o ../bin/alda alda.io/client
+ cd ..
+
+ #Build alda-player
+ fat_jar="build/libs/alda-player-fat.jar"
+ jvm_opts="-XX:+UseG1GC -XX:MaxGCPauseMillis=100 -Xmx1024m -Xms256m -DlogPath=tmplog"
+ cd "player"
+ ./gradlew -q -g . build
+ cat \
+ <(echo -e "#!/bin/sh\n\nexec java $jvm_opts -jar \$0 \"\$@\"\n\n\n") \
+ "$fat_jar" \
+ > ../bin/alda-player
}
package() {
cd "$srcdir/$_pkgname/bin"
install -Dm755 alda \
"${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 alda-player \
+ "${pkgdir}/usr/bin/${_pkgname}-player"
}