summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBalló György2018-02-15 10:51:56 +0000
committerBalló György2018-02-15 10:51:56 +0000
commitebf542f2a3dd5bad678086227d77a2edf9dba49f (patch)
tree460bc570a237a9581c5dcadd3716f5ee4db042c3
parentb2272c49187634cdfc0cc042111713fd57e4bde7 (diff)
downloadaur-ebf542f2a3dd5bad678086227d77a2edf9dba49f.tar.gz
Add Alduin
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD84
-rw-r--r--alduin.desktop14
-rw-r--r--alduin.pngbin23760 -> 0 bytes
-rw-r--r--alduin.sh3
5 files changed, 77 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41ae139c2414..7f06222b075d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,21 @@
pkgbase = alduin
- pkgdesc = Alduin is An RSS and Atom feed aggregator written in Electron
- pkgver = 1.4.0
- pkgrel = 3
- url = https://github.com/Xstoudi/alduin
- arch = i686
+ pkgdesc = RSS, Atom and JSON feed aggregator
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://alduinapp.github.io/
arch = x86_64
license = MIT
+ makedepends = git
+ makedepends = npm
+ makedepends = python2
depends = electron
- provides = alduin
- source = https://github.com/Xstoudi/alduin/releases/download/1.4.0/alduin-1.4.0-linux.zip
+ options = !strip
+ source = alduin-2.0.1.tar.gz::https://github.com/AlduinApp/alduin/archive/2.0.1.tar.gz
+ source = alduin.sh
source = alduin.desktop
- source = alduin.png
- md5sums = 4c693bf3ebdb36ec8297a336a78e80dc
- md5sums = 16f39375c22e73e8681524c1c2fc77c7
- md5sums = 81054e3f38fd14e93ccdddba6024d88d
+ sha256sums = fcb1afcd8563c5066fd2ba316776de6c2eedce359892c42647f3db919b5a1ea1
+ sha256sums = 04f441d21317c48e7df94dc8cf22934e906742b31a65f683a483b6069b9e7e16
+ sha256sums = 54174c4ac62fda2838de78c7b4dee7638e3befd4daded73548ce3a19f530748e
pkgname = alduin
diff --git a/PKGBUILD b/PKGBUILD
index 120b2e802bcb..2bf03b75fd85 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,62 @@
-# Maintainer: Aner Andros <code@anerandros.info>
+# $Id$
+# Contributor: Balló György <ballogyor+arch at gmail dot com>
-pkgbase=alduin
pkgname=alduin
-pkgrel=3
-pkgver=1.4.0
-pkgdesc="Alduin is An RSS and Atom feed aggregator written in Electron"
-url="https://github.com/Xstoudi/alduin"
-provides=('alduin')
-arch=('i686' 'x86_64')
-license=('MIT')
-depends=('electron')
-makedepends=()
-backup=()
-install=''
-source=(
- "${url}/releases/download/${pkgver}/${pkgname}-${pkgver}-linux.zip"
- "${pkgname}.desktop"
- "${pkgname}.png"
-)
+pkgver=2.0.1
+pkgrel=1
+pkgdesc="RSS, Atom and JSON feed aggregator"
+arch=(x86_64)
+url="https://alduinapp.github.io/"
+license=(MIT)
+depends=(electron)
+makedepends=(git npm python2)
+options=(!strip)
+source=($pkgname-$pkgver.tar.gz::https://github.com/AlduinApp/$pkgname/archive/$pkgver.tar.gz
+ $pkgname.sh
+ $pkgname.desktop)
+sha256sums=('fcb1afcd8563c5066fd2ba316776de6c2eedce359892c42647f3db919b5a1ea1'
+ '04f441d21317c48e7df94dc8cf22934e906742b31a65f683a483b6069b9e7e16'
+ '54174c4ac62fda2838de78c7b4dee7638e3befd4daded73548ce3a19f530748e')
-md5sums=('4c693bf3ebdb36ec8297a336a78e80dc'
- '16f39375c22e73e8681524c1c2fc77c7'
- '81054e3f38fd14e93ccdddba6024d88d')
-
-package() {
- install -d "$pkgdir"/opt
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i '/TrackerModal/d' src/script/components/app.jsx
+}
- cp -R "$srcdir"/linux-unpacked "$pkgdir"/opt/alduin
+build() {
+ cd $pkgname-$pkgver
+ npm uninstall 7zip-bin-linux --save-optional
+ npm run build
+ npm prune --production
+ npm rebuild --runtime=electron --target=$(</usr/lib/electron/version) --disturl=https://atom.io/download/electron --build-from-source
+}
- install -d "$pkgdir"/usr/bin
- ln -sf ../../opt/alduin/alduin "$pkgdir"/usr/bin/alduin
+package() {
+ mkdir -p "$pkgdir"/usr/{lib,share/pixmaps}
+ cp -r $pkgname-$pkgver "$pkgdir/usr/lib/$pkgname"
+ ln -s ../../lib/$pkgname/dist/assets/image/icon.png "$pkgdir/usr/share/pixmaps/$pkgname.png"
+ install -Dm755 $pkgname.sh "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.desktop "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 $pkgname-$pkgver/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -D -m644 "./${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
- install -D -m644 "./${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ # Clean up
+ find "$pkgdir/usr/lib/$pkgname/node_modules" \
+ -name "package.json" \
+ -exec sed -e "s|$srcdir/$pkgname|/usr/lib/$pkgname|" \
+ -i {} \; \
+ -or -name ".*" -prune -exec rm -r '{}' \; \
+ -or -name "*.gyp" -prune -exec rm -r '{}' \; \
+ -or -name "*.gypi" -prune -exec rm -r '{}' \; \
+ -or -name "*.mk" -prune -exec rm -r '{}' \; \
+ -or -name "*Makefile" -prune -exec rm -r '{}' \; \
+ -or -name "bin" -prune -exec rm -r '{}' \; \
+ -or -name "deps" -prune -exec rm -r '{}' \; \
+ -or -name "doc" -prune -exec rm -r '{}' \; \
+ -or -name "example" -prune -exec rm -r '{}' \; \
+ -or -name "man" -prune -exec rm -r '{}' \; \
+ -or -name "nan" -prune -exec rm -r '{}' \; \
+ -or -name "obj.target" -prune -exec rm -r '{}' \; \
+ -or -name "script" -prune -exec rm -r '{}' \; \
+ -or -name "test" -prune -exec rm -r '{}' \; \
+ -or -name "tmp" -prune -exec rm -r '{}' \;
}
diff --git a/alduin.desktop b/alduin.desktop
index 647e57870f94..0ef3f5ea5e64 100644
--- a/alduin.desktop
+++ b/alduin.desktop
@@ -1,10 +1,8 @@
[Desktop Entry]
-Name=alduin
-Comment=An RSS and Atom feed aggregator
-Exec="alduin"
-Icon=alduin
-Terminal=false
+Version=1.0
Type=Application
-StartupNotify=true
-Categories=GNOME;GTK;Development;Documentation;
-MimeType=text/plain;
+Name=Alduin
+Comment=RSS, Atom and JSON feed aggregator
+Exec=alduin
+Icon=alduin
+Categories=Network;News;
diff --git a/alduin.png b/alduin.png
deleted file mode 100644
index 7efe6e2c0e33..000000000000
--- a/alduin.png
+++ /dev/null
Binary files differ
diff --git a/alduin.sh b/alduin.sh
new file mode 100644
index 000000000000..b4d58d5c8708
--- /dev/null
+++ b/alduin.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+electron /usr/lib/alduin