summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAner Andros2017-01-01 18:02:07 +0000
committerAner Andros2017-01-01 18:02:07 +0000
commitf15acf588bfd35201610e26dd69c0a1fa4c6c4fc (patch)
treee9a28f8bcd85e461e73f3268c2b350b6a5621a3d
downloadaur-f15acf588bfd35201610e26dd69c0a1fa4c6c4fc.tar.gz
first version. tested locally and working
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
-rw-r--r--alduin.desktop10
-rw-r--r--alduin.pngbin0 -> 23760 bytes
4 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de3bd6d22d50
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = alduin
+ pkgdesc = Alduin is An RSS and Atom feed aggregator written in Electron
+ pkgver = 1.2.2
+ pkgrel = 1
+ url = https://github.com/Xstoudi/alduin
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = electron
+ provides = alduin
+ source = https://github.com/Xstoudi/alduin/releases/download/1.2.2/alduin-1.2.2-linux.zip
+ source = alduin.desktop
+ source = alduin.png
+ md5sums = db1a31d3c4068bafb5a47f8060a7ea41
+ md5sums = 16f39375c22e73e8681524c1c2fc77c7
+ md5sums = 81054e3f38fd14e93ccdddba6024d88d
+
+pkgname = alduin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1556a4c849aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Aner Andros <code@anerandros.info>
+
+pkgbase=alduin
+pkgname=alduin
+pkgrel=1
+pkgver=1.2.2
+pkgdesc="Alduin is An RSS and Atom feed aggregator written in Electron"
+url="https://github.com/Xstoudi/alduin"
+provides=('alduin')
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('electron')
+makedepends=()
+backup=()
+install=''
+source=(
+ "${url}/releases/download/${pkgver}/${pkgname}-${pkgver}-linux.zip"
+ "${pkgname}.desktop"
+ "${pkgname}.png"
+)
+
+md5sums=('db1a31d3c4068bafb5a47f8060a7ea41'
+ '16f39375c22e73e8681524c1c2fc77c7'
+ '81054e3f38fd14e93ccdddba6024d88d')
+
+package() {
+ install -d "$pkgdir"/opt
+
+ cp -R "$srcdir"/linux-unpacked "$pkgdir"/opt/alduin
+
+ install -d "$pkgdir"/usr/bin
+ ln -sf ../../opt/alduin/alduin "$pkgdir"/usr/bin/alduin
+
+ install -D -m644 "./${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m644 "./${pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+}
diff --git a/alduin.desktop b/alduin.desktop
new file mode 100644
index 000000000000..647e57870f94
--- /dev/null
+++ b/alduin.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=alduin
+Comment=An RSS and Atom feed aggregator
+Exec="alduin"
+Icon=alduin
+Terminal=false
+Type=Application
+StartupNotify=true
+Categories=GNOME;GTK;Development;Documentation;
+MimeType=text/plain;
diff --git a/alduin.png b/alduin.png
new file mode 100644
index 000000000000..7efe6e2c0e33
--- /dev/null
+++ b/alduin.png
Binary files differ