summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAggam Rahamim2023-01-14 11:35:04 +0200
committerAggam Rahamim2023-01-14 11:35:04 +0200
commitfbee3f59e73086932bbc99e18b82093f88381780 (patch)
treef9d655b838949c79031a7c002ffd96dea570aa9d
parent85e4da28f492ca120f44d07b85c8e5192b10932d (diff)
downloadaur-fbee3f59e73086932bbc99e18b82093f88381780.tar.gz
added 2 new fonts, added unzip as makedepends
-rwxr-xr-x[-rw-r--r--].SRCINFO12
-rwxr-xr-x[-rw-r--r--]PKGBUILD27
2 files changed, 25 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4df2e7eace14..b9b787dc9cb7 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,18 @@
pkgbase = alefbet
- pkgdesc = 2 Hebrew fonts (at the moment): the commonly used "David Libre", and the handwriting font "Gveret Levin".
- pkgver = 1.0
- pkgrel = 1
+ pkgdesc = 4 Hebrew fonts (at the moment): the commonly used "David Libre", the handwriting font "Gveret Levin", "Varela_Round" and "open-sans".
+ pkgver = 1.1
+ pkgrel = 2
arch = any
license = OFL
+ makedepends = unzip
noextract = GveretLevinAlefAlefAlef.zip
source = https://github.com/meirsadan/david-libre/releases/download/v1.001/DavidLibre_TTF_v1.001.zip
source = https://opensiddur.org/wp-content/uploads/fonts/GveretLevinAlefAlefAlef/GveretLevinAlefAlefAlef.zip
+ source = https://פונטיםבעברית.co.il/wp-content/uploads/2019/01/open-sans.zip
+ source = https://פונטיםבעברית.co.il/wp-content/uploads/2019/10/Varela_Round.zip
sha256sums = a66515bcdcda5abab7a86d945a8d89077916837f1128e44610e74e88bc41bb3f
sha256sums = 5df0379f71c8e8b1ddf00a4bda6693fa4520c40ca1f3e157bccbdfad4fb03959
+ sha256sums = 42af7ad1db6c8b8b67e9648d220b6ed0e01d8295b60fe554c9e3b727b948addb
+ sha256sums = 3835a054825cb7da8d8b937becea1d7013a75715475f714fe295d2833a478887
pkgname = alefbet
-
diff --git a/PKGBUILD b/PKGBUILD
index ec32aa9e3c43..546a321bd82d 100644..100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,38 @@
# Shalom Hevre!
pkgname=alefbet
-pkgver=1.0
-pkgrel=1
-pkgdesc="2 Hebrew fonts (at the moment): the commonly used \"David Libre\", and the handwriting font \"Gveret Levin\"."
+pkgver=1.1
+pkgrel=2
+pkgdesc="4 Hebrew fonts (at the moment): the commonly used \"David Libre\", the handwriting font \"Gveret Levin\", \"Varela_Round\" and \"open-sans\"."
arch=('any')
+makedepends=('unzip')
license=('OFL')
source=(
'https://github.com/meirsadan/david-libre/releases/download/v1.001/DavidLibre_TTF_v1.001.zip'
'https://opensiddur.org/wp-content/uploads/fonts/GveretLevinAlefAlefAlef/GveretLevinAlefAlefAlef.zip'
+ 'https://פונטיםבעברית.co.il/wp-content/uploads/2019/01/open-sans.zip'
+ 'https://פונטיםבעברית.co.il/wp-content/uploads/2019/10/Varela_Round.zip'
)
sha256sums=(
'a66515bcdcda5abab7a86d945a8d89077916837f1128e44610e74e88bc41bb3f'
'5df0379f71c8e8b1ddf00a4bda6693fa4520c40ca1f3e157bccbdfad4fb03959'
+ '42af7ad1db6c8b8b67e9648d220b6ed0e01d8295b60fe554c9e3b727b948addb'
+ '3835a054825cb7da8d8b937becea1d7013a75715475f714fe295d2833a478887'
)
-noextract=(
- 'GveretLevinAlefAlefAlef.zip'
-)
-package() {
+noextract=('GveretLevinAlefAlefAlef.zip')
- install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE" # they all use the OFL
+package() {
+ install -Dm644 OFL.txt "$pkgdir/usr/share/licenses/$pkgname/OFL" # for David Libre, Gveret Levin, and Varela Round
- #David Libre
- install -Dm644 *.ttf -t "${pkgdir}/usr/share/fonts/TTF/"
+ unzip Varela_Round.zip
+ install -Dm644 *.ttf -t "${pkgdir}/usr/share/fonts/TTF/" #David Libre & Varela Round
#Gveret Levin
unzip GveretLevinAlefAlefAlef.zip -d gevretLevin/
install -Dm644 gevretLevin/otf/GveretLevinAlefAlefAlef-Regular.otf -t "$pkgdir/usr/share/fonts/OTF/"
+ #open-sans
+ unzip open-sans.zip
+ install -Dm644 open-sans/*.ttf -t "${pkgdir}/usr/share/fonts/TTF/"
+ install -Dm644 open-sans/LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/Apache"
} \ No newline at end of file