summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0xjac2021-10-22 16:20:35 +0200
committer0xjac2021-10-22 16:20:35 +0200
commitbb6b243841e47b20f4863e9a34b10b4119a0216e (patch)
treea5035adc514f3994fe7d8fff5bf6093fe4a3a5a1
downloadaur-bb6b243841e47b20f4863e9a34b10b4119a0216e.tar.gz
pkg: v0.11.1-1
initial release
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a073e146e08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = alephium-wallet-bin
+ pkgdesc = The official Alephium desktop wallet.
+ pkgver = 0.11.1
+ pkgrel = 1
+ url = https://github.com/alephium/alephium-wallet
+ arch = x86_64
+ license = LGPL3
+ provides = alephium-wallet
+ conflicts = alephium-wallet
+ source_x86_64 = https://github.com/alephium/alephium-wallet/releases/download/v0.11.1/alephium-wallet-linux-amd64-0.11.1.deb
+ sha256sums_x86_64 = 2ffa3a3a5a7a7e6fc61f3a268176f4cc7bb0699480156ad40a16bd306d07f417
+
+pkgname = alephium-wallet-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f13e89175ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: 0xjac <aur at 0xjac dot com>
+
+pkgname=alephium-wallet-bin
+pkgdesc="The official Alephium desktop wallet."
+pkgver=0.11.1
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/alephium/alephium-wallet"
+license=('LGPL3')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+source_x86_64=("https://github.com/alephium/${pkgname%-bin}/releases/download/v$pkgver/${pkgname%-bin}-linux-amd64-$pkgver.deb")
+sha256sums_x86_64=('2ffa3a3a5a7a7e6fc61f3a268176f4cc7bb0699480156ad40a16bd306d07f417')
+
+package() {
+ tar -xf data.tar.xz -C "$pkgdir"
+
+ # Move the icon to the right directory.
+ mkdir -p "$pkgdir/usr/share/icons/hicolor/512x512/apps/"
+ mv "$pkgdir/usr/share/icons/hicolor/0x0/apps/alephium.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/alephium.png"
+ rm -r "$pkgdir/usr/share/icons/hicolor/0x0"
+}