summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2015-03-05 19:33:33 +0100
committerCarsten Teibes2015-03-05 19:33:33 +0100
commit4b927beb508b55edaabdd0e5fc1d87fd97eb399b (patch)
tree80911378ef75e5cce87e9266ca5a67522f4fed57
downloadaur-4b927beb508b55edaabdd0e5fc1d87fd97eb399b.tar.gz
[add] alephone-evil 1.0
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
-rw-r--r--alephone-evil.desktop7
-rwxr-xr-xalephone-evil.sh5
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be143722b248
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = alephone-evil
+ pkgdesc = A radical new scenario for the AlephOne engine
+ pkgver = 1.0
+ pkgrel = 2
+ url = http://trilogyrelease.bungie.org/
+ arch = any
+ license = unknown
+ depends = alephone
+ source = http://files3.bungie.org/trilogy/MarathonEvil.zip
+ source = alephone-evil.sh
+ source = alephone-evil.desktop
+ sha256sums = 25ade4be0e9f0a4456511830e1abf55f48a095390bae8cef02a16771e5fad122
+ sha256sums = 298cd98fc67350c9462d7962fd95db21451db2adc21716c88342a1bf5942b0af
+ sha256sums = 287df7f3c6e4b8fd3161fd0a62c01de35525613f857568073c2213d263b0aec9
+
+pkgname = alephone-evil
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13cb0e7c85af
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: carstene1ns <arch carsten-teibes de> - http://git.io/ctPKG
+# Contributor: Luis Medina <noxein@yahoo.com>
+
+pkgname=alephone-evil
+pkgver=1.0
+pkgrel=2
+pkgdesc="A radical new scenario for the AlephOne engine"
+arch=('any')
+url="http://trilogyrelease.bungie.org/"
+license=('unknown')
+depends=('alephone')
+source=("http://files3.bungie.org/trilogy/MarathonEvil.zip"
+ "$pkgname.sh"
+ "$pkgname.desktop")
+sha256sums=('25ade4be0e9f0a4456511830e1abf55f48a095390bae8cef02a16771e5fad122'
+ '298cd98fc67350c9462d7962fd95db21451db2adc21716c88342a1bf5942b0af'
+ '287df7f3c6e4b8fd3161fd0a62c01de35525613f857568073c2213d263b0aec9')
+
+prepare() {
+ rm -rf "Marathon EVIL"/Themes/Default/CVS
+}
+
+package() {
+ # scenario data
+ install -d "$pkgdir"/usr/share/alephone/scenarios
+ cp -r "Marathon EVIL" "$pkgdir"/usr/share/alephone/scenarios/evil
+
+ # sane permissions
+ find "$pkgdir"/usr/share/alephone/scenarios/evil -type f -exec chmod 644 {} \;
+
+ # launcher script and .desktop file
+ install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 $pkgname.desktop "$pkgdir"/usr/share/applications/$pkgname.desktop
+}
diff --git a/alephone-evil.desktop b/alephone-evil.desktop
new file mode 100644
index 000000000000..3d2729e09d33
--- /dev/null
+++ b/alephone-evil.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Exec=alephone-evil
+Icon=alephone
+Name=EVIL (Aleph One)
+Categories=Game;ActionGame;
+Comment=A FPS game
diff --git a/alephone-evil.sh b/alephone-evil.sh
new file mode 100755
index 000000000000..7b8a17b67d28
--- /dev/null
+++ b/alephone-evil.sh
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+export ALEPHONE_DATA=/usr/share/alephone:/usr/share/alephone/scenarios/evil
+
+exec /usr/bin/alephone "$@"