summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Teibes2017-10-02 22:29:09 +0200
committerCarsten Teibes2017-10-02 22:29:09 +0200
commit9bbece2d6f0eb7eccdcc61154a455486996be770 (patch)
tree9677a19554a7576853afc75df55b36cf4bb350e8
parent4b927beb508b55edaabdd0e5fc1d87fd97eb399b (diff)
downloadaur-9bbece2d6f0eb7eccdcc61154a455486996be770.tar.gz
[fix] Cleanup
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
-rw-r--r--alephone-evil.desktop2
-rw-r--r--[-rwxr-xr-x]alephone-evil.sh2
4 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be143722b248..b786fd20b84c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = alephone-evil
- pkgdesc = A radical new scenario for the AlephOne engine
+ pkgdesc = A radical new scenario for the Aleph One engine
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
url = http://trilogyrelease.bungie.org/
arch = any
license = unknown
@@ -10,8 +10,8 @@ pkgbase = alephone-evil
source = alephone-evil.sh
source = alephone-evil.desktop
sha256sums = 25ade4be0e9f0a4456511830e1abf55f48a095390bae8cef02a16771e5fad122
- sha256sums = 298cd98fc67350c9462d7962fd95db21451db2adc21716c88342a1bf5942b0af
- sha256sums = 287df7f3c6e4b8fd3161fd0a62c01de35525613f857568073c2213d263b0aec9
+ sha256sums = 73a27f33ab234dc96bf63105d6f8b98a730247ff7611d682b967173e7bdb2466
+ sha256sums = 68247e727749dcf17439fc98b92f9ad6a86ff795e3f5859ec6a3c4bdd174805c
pkgname = alephone-evil
diff --git a/PKGBUILD b/PKGBUILD
index 13cb0e7c85af..e6881cecaa87 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=alephone-evil
pkgver=1.0
-pkgrel=2
-pkgdesc="A radical new scenario for the AlephOne engine"
+pkgrel=3
+pkgdesc="A radical new scenario for the Aleph One engine"
arch=('any')
url="http://trilogyrelease.bungie.org/"
license=('unknown')
@@ -13,20 +13,21 @@ source=("http://files3.bungie.org/trilogy/MarathonEvil.zip"
"$pkgname.sh"
"$pkgname.desktop")
sha256sums=('25ade4be0e9f0a4456511830e1abf55f48a095390bae8cef02a16771e5fad122'
- '298cd98fc67350c9462d7962fd95db21451db2adc21716c88342a1bf5942b0af'
- '287df7f3c6e4b8fd3161fd0a62c01de35525613f857568073c2213d263b0aec9')
+ '73a27f33ab234dc96bf63105d6f8b98a730247ff7611d682b967173e7bdb2466'
+ '68247e727749dcf17439fc98b92f9ad6a86ff795e3f5859ec6a3c4bdd174805c')
prepare() {
+ # delete leftover
rm -rf "Marathon EVIL"/Themes/Default/CVS
}
package() {
# scenario data
- install -d "$pkgdir"/usr/share/alephone/scenarios
- cp -r "Marathon EVIL" "$pkgdir"/usr/share/alephone/scenarios/evil
+ install -d "$pkgdir"/usr/share/AlephOne/scenarios
+ cp -r "Marathon EVIL" "$pkgdir"/usr/share/AlephOne/scenarios/evil
# sane permissions
- find "$pkgdir"/usr/share/alephone/scenarios/evil -type f -exec chmod 644 {} \;
+ find "$pkgdir"/usr/share/AlephOne/scenarios/evil -type f -exec chmod 644 {} \;
# launcher script and .desktop file
install -Dm755 $pkgname.sh "$pkgdir"/usr/bin/$pkgname
diff --git a/alephone-evil.desktop b/alephone-evil.desktop
index 3d2729e09d33..6c13c9a07c24 100644
--- a/alephone-evil.desktop
+++ b/alephone-evil.desktop
@@ -4,4 +4,4 @@ Exec=alephone-evil
Icon=alephone
Name=EVIL (Aleph One)
Categories=Game;ActionGame;
-Comment=A FPS game
+Comment=An FPS game
diff --git a/alephone-evil.sh b/alephone-evil.sh
index 7b8a17b67d28..f7ac3356b142 100755..100644
--- a/alephone-evil.sh
+++ b/alephone-evil.sh
@@ -1,5 +1,5 @@
#!/bin/sh
-export ALEPHONE_DATA=/usr/share/alephone:/usr/share/alephone/scenarios/evil
+export ALEPHONE_DATA=/usr/share/AlephOne:/usr/share/AlephOne/scenarios/evil
exec /usr/bin/alephone "$@"