summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsiphr2022-06-21 12:03:01 +0100
committersiphr2022-06-21 12:03:01 +0100
commit7eb0b7f4a486c9210e661a1264fca22705a18c80 (patch)
tree3ed3e2fe709a1da188b6f9b9d354fe5f886dae93
downloadaur-7eb0b7f4a486c9210e661a1264fca22705a18c80.tar.gz
Alephs package for list pakistani emergency services.
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD34
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2f437422a176
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = alephs
+ pkgdesc = List of Pakistan's emergency services.
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://www.techtum.dev/work-spcs-220121.html
+ arch = any
+ license = MIT
+ depends = python
+ source = https://github.com/siphr/alephs/archive/refs/tags/0.5.tar.gz
+ md5sums = SKIP
+
+pkgname = alephs
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..8c33dec53db4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: siphr <archlinux@techtum.dev>
+
+pkgname=alephs
+pkgver=0.5
+pkgrel=1
+pkgdesc="List of Pakistan's emergency services."
+depends=(python)
+arch=(any)
+
+source=("https://github.com/siphr/alephs/archive/refs/tags/$pkgver.tar.gz")
+url=https://www.techtum.dev/work-spcs-220121.html
+license=('MIT')
+
+build() {
+ echo "BUILDING..."
+ cd "$srcdir/$pkgname-$pkgver/pip/"
+ python setup.py build
+
+ echo -e '#!/bin/sh\n\nexec python -m alephs.alephs "$@"' > _alephs
+}
+
+package() {
+ echo "INSTALLING..."
+ cd "$srcdir/$pkgname-$pkgver/pip/"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+
+ mkdir -p $pkgdir/usr/bin
+ mv _alephs "$pkgdir/usr/bin/alephs"
+ chmod +x $pkgdir/usr/bin/alephs
+
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ echo 'Finished setting up ALEPHS.'
+}
+md5sums=('SKIP')