summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-12-26 13:22:50 -0600
committerLuis Martinez2021-12-26 13:22:50 -0600
commit810c42db5bdde35a23a6207f7eac85ac615fe939 (patch)
tree1a5eb21301e4ece877ff636beb05762faf261084
parent97afcd6136a8661fbee05355ecc50832daa5bdf0 (diff)
downloadaur-810c42db5bdde35a23a6207f7eac85ac615fe939.tar.gz
update to 8.7.0
-rw-r--r--.SRCINFO10
-rw-r--r--CHANGELOG.md113
-rw-r--r--PKGBUILD17
3 files changed, 127 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 086774b406a6..a6c307cba48f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = alerta
pkgdesc = A tool used to consolidate and de-duplicate alerts from multiple sources
- pkgver = 8.6.4
+ pkgver = 8.7.0
pkgrel = 1
url = https://github.com/alerta/alerta
arch = any
license = APACHE
makedepends = python-setuptools
- depends = python>=3.6
+ depends = python>=3.7
depends = python-blinker
depends = python-bcrypt
depends = python-cryptography
@@ -17,7 +17,6 @@ pkgbase = alerta
depends = python-mohawk
depends = python-pyaml
depends = python-pyjwt
- depends = python-pymongo
depends = python-pyparsing
depends = python-pytz
depends = python-requests
@@ -25,11 +24,12 @@ pkgbase = alerta
depends = python-sentry_sdk
optdepends = python-psycopg2
optdepends = postgresql
+ optdepends = python-pymongo
optdepends = mongodb
- source = alerta-8.6.4.tar.gz::https://github.com/alerta/alerta/archive/v8.6.4.tar.gz
+ source = alerta-8.7.0.tar.gz::https://github.com/alerta/alerta/archive/v8.7.0.tar.gz
source = alertad.service
source = alerta.sysusers
- sha256sums = 94c9af6ccead37f19e85756ea1b3255dd9f6b95a6d6087e1ffb61ff0fa8545e9
+ sha256sums = b2f515652ad40beb4163566ff4ecff366550d253a656eafcc5c5568a3d0f914f
sha256sums = 4449acb346807229e4cbfeed68d9ba6006a165e65dec09487fb6e627088016c2
sha256sums = f0a2f76266ba07275ab2baeab1497dfb2946305e85ae68e3b34dd14e2ac47423
diff --git a/CHANGELOG.md b/CHANGELOG.md
new file mode 100644
index 000000000000..1f4cbdfe892b
--- /dev/null
+++ b/CHANGELOG.md
@@ -0,0 +1,113 @@
+## v8.6.0 (2021-05-20)
+
+### Refactor
+
+- convert formatted strings to f-strings (more) (#1522)
+- convert tests to use f-strings (#1521)
+- convert formatted strings to f-strings (#1520)
+
+### Feat
+
+- add escalate severity custom action plugin (#1519)
+- Add support for user-defined API key (#1518)
+- log dismissing notes to alert history (#1507)
+- add default blackout duration to config endpoint (#1506)
+- support readonly users (#1505)
+
+### Fix
+
+- change housekeeping delete threshold to seconds (#1508)
+- config setting default environment for webhooks (#1510)
+- read LDAP_BIND_PASSWORD from environment variable (#1509)
+
+## v8.5.0 (2021-04-18)
+
+### Fix
+
+- **grafana**: ensure tags work on multi timeseries alert (#1450) (#1490)
+- add related id to note reponse (#1499)
+- **deps**: bump lxml from 4.6.2 to 4.6.3 (#1486)
+
+### Refactor
+
+- create "query builders" for all data models (#1446)
+
+### Feat
+
+- support custom top10 report sizes (#1498)
+- add alert origin to blackout options (#1497)
+- add support for custom auth scopes (#1479)
+
+## v8.4.1 (2021-02-28)
+
+### Fix
+
+- **deps**: bump multiple package dependencies (#1470)
+
+## v8.4.0 (2021-02-27)
+
+### Fix
+
+- **auth**: HMAC was falling thru to catchall if auth required (#1470)
+- **tests**: enforce authentication for forwarder test (#1471)
+- **deps**: update PyJWT to v2.0.0 (#1441)
+- request filter fixes in logging.py (#1442)
+
+### Refactor
+
+- use more enums and class properties (#1444)
+
+### Feat
+
+- **plugin,webhook**: Add support for custom error responses (#1466)
+- add pagination support to collection responses (#1443)
+- **plugin**: add timeout policy plugin to enforce ack and shelve timeouts (#1410)
+
+## v8.3.3 (2021-01-06)
+
+### Fix
+
+- move root logger config key back to top level (#1438)
+
+## v8.3.2 (2021-01-02)
+
+### Fix
+
+- log level not set correctly if DEBUG enabled (#1437)
+- do not override envvar config for GitLab and Keycloak (#1431)
+
+## v8.3.1 (2020-12-13)
+
+### Fix
+
+- **search**: use phrase token when searching arrays (#1426)
+- **tests**: only temporarily modify the os.environ (#1423)
+- **build**: run tests against correct branch
+- read built-in plugin config from env vars (#1422)
+
+### Refactor
+
+- **config**: simplify config settings from env vars (#1424)
+
+## v8.3.0 (2020-12-12)
+
+### Feat
+
+- add allowed environments to config endpoint (#1421)
+- add colors for Ack and Shelved statuses (#1420)
+- add syslog logging output format (#1417)
+
+### Fix
+
+- remove redundant logging messages
+- use string enumerated types where possible (#1419)
+- add "X-Request-ID" as CORS header (#1418)
+- add requestId to error responses (#1415)
+- **webhook**: set alert status from action, not directly (#1409)
+- **mongodb**: optional query for raw_data and history (#1408)
+- **postgres**: optional query for raw_data and history (#1407)
+- set alert heartbeat timeout from alert timeout
+
+### Perf
+
+- **db**: Do not query for rawData or history if not required
diff --git a/PKGBUILD b/PKGBUILD
index ffd5704999ae..3cea5248a5a2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,14 @@
# Contributor: Michael Clayfield <me@michaelclayfield.com>
pkgname=alerta
-pkgver=8.6.4
+pkgver=8.7.0
pkgrel=1
pkgdesc="A tool used to consolidate and de-duplicate alerts from multiple sources"
arch=('any')
url="https://github.com/alerta/alerta"
license=('APACHE')
depends=(
- 'python>=3.6'
+ 'python>=3.7'
'python-blinker'
'python-bcrypt'
'python-cryptography'
@@ -20,18 +20,18 @@ depends=(
'python-mohawk'
'python-pyaml'
'python-pyjwt'
- 'python-pymongo'
'python-pyparsing'
'python-pytz'
'python-requests'
'python-requests-hawk'
'python-sentry_sdk')
-optdepends=('python-psycopg2' 'postgresql' 'mongodb')
+optdepends=('python-psycopg2' 'postgresql' 'python-pymongo' 'mongodb')
makedepends=('python-setuptools')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
- "alertad.service"
- "alerta.sysusers")
-sha256sums=('94c9af6ccead37f19e85756ea1b3255dd9f6b95a6d6087e1ffb61ff0fa8545e9'
+source=(
+ "$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
+ "alertad.service"
+ "alerta.sysusers")
+sha256sums=('b2f515652ad40beb4163566ff4ecff366550d253a656eafcc5c5568a3d0f914f'
'4449acb346807229e4cbfeed68d9ba6006a165e65dec09487fb6e627088016c2'
'f0a2f76266ba07275ab2baeab1497dfb2946305e85ae68e3b34dd14e2ac47423')
@@ -43,6 +43,7 @@ build() {
## tests require a server
package() {
+ export PYTHONHASHSEED=0
cd "alerta-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
install -Dm644 "$srcdir/alerta.sysusers" "$pkgdir/usr/lib/sysusers.d/alerta.conf"