summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNagy Gabor2015-06-21 19:13:34 +0200
committerNagy Gabor2015-06-21 19:13:34 +0200
commit13dc5ca9ed8eddbf10536297774a264878314c15 (patch)
tree6af989800843f249ed0ca0c5efbd9b34f275b58c
downloadaur-13dc5ca9ed8eddbf10536297774a264878314c15.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
-rw-r--r--alevt.desktop8
-rw-r--r--alevt.install6
4 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9791b4689ca7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by makepkg 4.2.1
+# Sun Jun 21 17:12:09 UTC 2015
+pkgbase = alevt
+ pkgdesc = A teletext/videotext decoder and browser for the vbi device and X11
+ pkgver = 1.6.3
+ pkgrel = 3
+ url = http://www.goron.de/~froese
+ install = alevt.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libpng
+ depends = libx11
+ source = http://fossies.org/linux/misc/alevt-1.6.3.tar.gz
+ source = alevt.desktop
+ md5sums = 9d3878030ca25fe76c5d4f288f7b4d0d
+ md5sums = 10dbfcafa9ff0b5f9ce17ab98e7eadec
+
+pkgname = alevt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e45383a8b71
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Nagy Gabor <Gabor.V.Nagy@@gmail.com>
+# Based on the PKGBUILD of Víctor Martínez Romanos <vmromanos@gmail.com>
+
+pkgname=alevt
+pkgver=1.6.3
+pkgrel=3
+pkgdesc="A teletext/videotext decoder and browser for the vbi device and X11"
+arch=('i686' 'x86_64')
+url="http://www.goron.de/~froese"
+license=('GPL')
+depends=('libpng' 'libx11')
+install=alevt.install
+#source=(http://www.goron.de/~froese/alevt/$pkgname-$pkgver.tar.gz alevt.desktop)
+source=(http://fossies.org/linux/misc/$pkgname-$pkgver.tar.gz alevt.desktop)
+md5sums=('9d3878030ca25fe76c5d4f288f7b4d0d'
+ '10dbfcafa9ff0b5f9ce17ab98e7eadec')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ install -m755 -d $pkgdir/usr/{bin,share/man/man1,share/pixmaps,share/applications}
+ install -m755 alevt alevt-cap alevt-date $pkgdir/usr/bin
+ install -m644 alevt.1x alevt-date.1 alevt-cap.1 $pkgdir/usr/share/man/man1
+ install -m644 contrib/mini-alevt.xpm $pkgdir/usr/share/pixmaps
+ install -m644 $srcdir/alevt.desktop $pkgdir/usr/share/applications/
+}
diff --git a/alevt.desktop b/alevt.desktop
new file mode 100644
index 000000000000..0b49accfbe7e
--- /dev/null
+++ b/alevt.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=AleVT
+Comment=X11 Teletext browser
+Exec=alevt
+Icon=mini-alevt
+Terminal=false
+Type=Application
+Categories=Application;AudioVideo;
diff --git a/alevt.install b/alevt.install
new file mode 100644
index 000000000000..ccc84732150f
--- /dev/null
+++ b/alevt.install
@@ -0,0 +1,6 @@
+# arg 1: the new package version
+post_install() {
+ echo
+ echo "NOTE: Remember to add your user to the video group."
+ echo
+}