summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-08-29 17:54:26 +0200
committerbegin-theadventure2023-08-29 17:54:26 +0200
commit47607699d04442bae521595c6bbe6caefb03ca7e (patch)
tree8036a60a211c4a1122f88f75d91a392563fed149
parent695b9616425fa86d4393330a01d4971e0bc4c28b (diff)
downloadaur-47607699d04442bae521595c6bbe6caefb03ca7e.tar.gz
mv instead of cp, don't install doc/license
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 4 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b657c5ac2a0..0577a4a304ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,12 +9,8 @@ pkgbase = alfae-bin
conflicts = alfae
options = !strip
source = alfae-1.4.1.zip::https://github.com/suchmememanyskill/Alfae/releases/download/1.4.1/Linux.zip
- source = https://raw.githubusercontent.com/suchmememanyskill/Alfae/1.4.1/Launcher/Assets/icon.png
- source = https://raw.githubusercontent.com/suchmememanyskill/Alfae/1.4.1/README.md
- source = https://raw.githubusercontent.com/suchmememanyskill/Alfae/1.4.1/LICENSE
+ source = https://github.com/suchmememanyskill/Alfae/raw/1.4.1/Launcher/Assets/icon.png
sha256sums = 33027a73c17561776e938f9b7c5ca83a8a3a0d3bf000e147dbe60b7d0996c4e9
sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
pkgname = alfae-bin
diff --git a/PKGBUILD b/PKGBUILD
index adca62e57128..224e79c110a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,12 +12,8 @@ provides=($_pkgname)
conflicts=($_pkgname)
options=('!strip')
source=("$_pkgname-$pkgver.zip::$url/releases/download/$pkgver/Linux.zip"
- "https://raw.githubusercontent.com/suchmememanyskill/Alfae/$pkgver/Launcher/Assets/icon.png"
- "https://raw.githubusercontent.com/suchmememanyskill/Alfae/$pkgver/README.md"
- "https://raw.githubusercontent.com/suchmememanyskill/Alfae/$pkgver/LICENSE")
+ "$url/raw/$pkgver/Launcher/Assets/icon.png")
sha256sums=('33027a73c17561776e938f9b7c5ca83a8a3a0d3bf000e147dbe60b7d0996c4e9'
- 'SKIP'
- 'SKIP'
'SKIP')
prepare() {
@@ -36,13 +32,10 @@ prepare() {
package() {
# Create folders
- mkdir -p $pkgdir/opt
- mkdir -p $pkgdir/usr/bin
+ mkdir -p "$pkgdir/opt/Alfae" "$pkgdir/usr/bin"
# Install
- cp -r Release $pkgdir/opt/Alfae
+ mv Release/* "$pkgdir/opt/Alfae"
ln -s /opt/Alfae/Alfae $pkgdir/usr/bin/$_pkgname
install -Dm644 icon.png "$pkgdir/usr/share/icons/hicolor/512x512/apps/$_pkgname.png"
install -Dm644 $_pkgname.desktop -t "$pkgdir/usr/share/applications"
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
}