summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Maier2020-03-27 11:11:03 +0100
committerThomas Maier2020-03-27 11:11:03 +0100
commitf6f27137d5c126edd498aa3546afc138ef539226 (patch)
tree101fe52dba3e219cb536595bc76208205ee05acb
downloadaur-f6f27137d5c126edd498aa3546afc138ef539226.tar.gz
initial PKGBUILD
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD21
-rw-r--r--alfaview.install9
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7812f3f47e18
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = alfaview
+ pkgdesc = High quality audio video conferencing for professional online meetings and live classes
+ pkgver = 8.3.1
+ pkgrel = 1
+ url = https://alfaview.com/
+ install = alfaview.install
+ arch = x86_64
+ license = unknown
+ depends = ttf-roboto
+ depends = libsecret
+ depends = xdg-utils
+ depends = freetype2
+ depends = fontconfig
+ depends = gst-plugins-bad
+ depends = libxfixes
+ depends = alsa-lib
+ depends = libxkbcommon
+ depends = dbus
+ noextract = alfaview_8.3.1.deb
+ options = !strip
+ source = https://production-alfaview-assets.alfaview.com/stable/linux/alfaview_8.3.1.deb
+ sha256sums = 5a335c63727713991a998c9519c1c6c671f6a90287e025f97edc7c7a93eb2fd2
+
+pkgname = alfaview
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c27b694ebfb3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Thomas Maier <contact@thomas-maier.net>
+pkgname=alfaview
+pkgver=8.3.1
+pkgrel=1
+pkgdesc='High quality audio video conferencing for professional online meetings and live classes'
+arch=('x86_64')
+url='https://alfaview.com/'
+license=('unknown')
+# not sure about the deps, copy-pasted from debian package (feedback required)
+depends=('ttf-roboto' 'libsecret' 'xdg-utils' 'freetype2' 'fontconfig' 'gst-plugins-bad' 'libxfixes' 'alsa-lib' 'libxkbcommon' 'dbus')
+options=('!strip')
+install="$pkgname.install"
+source=("https://production-alfaview-assets.alfaview.com/stable/linux/${pkgname}_${pkgver}.deb")
+noextract=("${pkgname}_${pkgver}.deb")
+sha256sums=('5a335c63727713991a998c9519c1c6c671f6a90287e025f97edc7c7a93eb2fd2')
+
+package() {
+ bsdtar -O -xf "${pkgname}_${pkgver}.deb" data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -sf /opt/alfaview/alfaview "${pkgdir}/usr/bin/alfaview"
+}
diff --git a/alfaview.install b/alfaview.install
new file mode 100644
index 000000000000..c05170c096d2
--- /dev/null
+++ b/alfaview.install
@@ -0,0 +1,9 @@
+post_upgrade() {
+ printf "$(tput bold)$(tput setaf 3)IMPORTANT: MIME types are NOT registered automatically$(tput sgr0)\n"
+ printf "$(tput bold)$(tput setaf 3)postinst from debian package: $(tput sgr0)\n"
+ printf "$(tput bold)$(tput setaf 3)xdg-mime default /usr/share/applications/alfaview.desktop x-scheme-handler/alfaview\nxdg-mime default /usr/share/applications/alfaview.desktop x-scheme-handler/alfatraining$(tput sgr0)\n"
+}
+
+post_install() {
+ post_upgrade
+}