summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobin Härle2021-12-09 12:01:53 +0100
committerRobin Härle2021-12-09 12:01:53 +0100
commitbc7f106c49ac14095bce07c6c1bd8c243cc3aa02 (patch)
tree8a2a79b9d572aa416c58d6ffd7b214161b20568a
downloadaur-bc7f106c49ac14095bce07c6c1bd8c243cc3aa02.tar.gz
initial commit (8.34.0)
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD32
-rw-r--r--alfaview-beta.install10
4 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7bc25d69513c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = alfaview-beta
+ pkgdesc = High quality audio video conferencing for professional online meetings and live classes
+ pkgver = 8.34.0
+ pkgrel = 1
+ url = https://alfaview.com/
+ install = alfaview-beta.install
+ arch = x86_64
+ license = unknown
+ depends = ttf-roboto
+ depends = libsecret
+ depends = xdg-utils
+ depends = freetype2
+ depends = fontconfig
+ depends = gst-plugins-bad
+ depends = libxfixes
+ depends = alsa-lib
+ depends = libxkbcommon
+ depends = dbus
+ depends = libpulse
+ provides = alfaview=8.34.0
+ conflicts = alfaview
+ noextract = alfaview_8.34.0.deb
+ options = !strip
+ source = https://production-alfaview-assets.alfaview.com/beta/linux/alfaview_8.34.0.deb
+ sha256sums = f396ecbba97f07e9479231415cd43d044cce9f5a184ec160ba7806d3aa7d9c3d
+
+pkgname = alfaview-beta
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d30e4965b276
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*
+!alfaview-beta.install
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f17717a0de1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Robin H. <robin at blckct dot io>
+pkgname=alfaview-beta
+pkgver=8.34.0
+pkgrel=1
+pkgdesc='High quality audio video conferencing for professional online meetings and live classes'
+arch=('x86_64')
+url='https://alfaview.com/'
+license=('unknown')
+# not sure about the deps, copy-pasted from debian package (feedback required)
+depends=('ttf-roboto' 'libsecret' 'xdg-utils' 'freetype2' 'fontconfig' 'gst-plugins-bad' 'libxfixes' 'alsa-lib' 'libxkbcommon' 'dbus' 'libpulse')
+conflicts=('alfaview')
+provides=("alfaview=${pkgver}")
+options=('!strip')
+install="$pkgname.install"
+source=("https://production-alfaview-assets.alfaview.com/beta/linux/alfaview_${pkgver}.deb")
+noextract=("alfaview_${pkgver}.deb")
+sha256sums=('f396ecbba97f07e9479231415cd43d044cce9f5a184ec160ba7806d3aa7d9c3d')
+
+
+prepare() {
+ mkdir -p deb-data
+ bsdtar -O -xf "alfaview_${pkgver}.deb" data.tar.xz | bsdtar -C ./deb-data -xJf -
+ # Adding beta update chennel to settings to avoid update notification on startup
+ mkdir -p ~/.local/share/alfaview/settings
+ echo $'[General]\nDeployChannel=beta' > ~/.local/share/alfaview/settings/core_settings_local.ini
+}
+
+package() {
+ mv deb-data/* "${pkgdir}/"
+ mkdir -p "${pkgdir}/usr/bin"
+ ln -sf /opt/alfaview/alfaview "${pkgdir}/usr/bin/alfaview"
+}
diff --git a/alfaview-beta.install b/alfaview-beta.install
new file mode 100644
index 000000000000..cef491c347a1
--- /dev/null
+++ b/alfaview-beta.install
@@ -0,0 +1,10 @@
+post_upgrade() {
+ printf "$(tput bold)$(tput setaf 3)IMPORTANT: MIME types are NOT registered automatically$(tput sgr0)\n"
+ printf "$(tput bold)$(tput setaf 3)postinst from debian package: $(tput sgr0)\n"
+ printf "$(tput bold)$(tput setaf 3)xdg-mime default /usr/share/applications/alfaview.desktop x-scheme-handler/alfaview\nxdg-mime default /usr/share/applications/alfaview.desktop x-scheme-handler/alfatraining$(tput sgr0)\n"
+}
+
+post_install() {
+ post_upgrade
+}
+