summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-11-01 12:32:57 +0100
committerAlexander F. Rødseth2018-11-01 12:32:57 +0100
commit0c50eb94b08d25b1fcbb0b63f8f8968300950f2b (patch)
treef8c7141d78dc9c199800d845b248337600d42650
parent6ff1560b6e37b69457bf178da9068abf44ef1dee (diff)
downloadaur-0c50eb94b08d25b1fcbb0b63f8f8968300950f2b.tar.gz
Update to 1.12
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD28
2 files changed, 20 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62b4e04b7181..472c38d1c07d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,17 @@
# Generated by mksrcinfo v8
-# Wed Oct 31 11:31:07 UTC 2018
+# Thu Nov 1 11:32:50 UTC 2018
pkgbase = algernon
- pkgdesc = Single executable web server with Lua, Markdown, QUIC and Pongo2 support
- pkgver = 1.11.0
- pkgrel = 2
+ pkgdesc = Small self-contained web server with Lua, Markdown, QUIC, Redis and PostgreSQL support
+ pkgver = 1.12.0
+ pkgrel = 1
url = https://algernon.roboticoverlords.org/
arch = x86_64
license = MIT
makedepends = git
- makedepends = go-pie
- depends = redis
+ makedepends = go
optdepends = mariadb: For using the MariaDB/MySQL database backend
optdepends = postgresql: For using the PostgreSQL database backend
- backup = etc/algernon/serverconf.lua
- backup = usr/lib/systemd/system/algernon.service
+ optdepends = redis: For using the Redis database backend
source = git+https://github.com/xyproto/algernon#commit=b23b6d52e0eb32581d00483e0f439d7c305434b2
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 58798be682ff..51764b5d567e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,23 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.11.0
-pkgrel=2
-pkgdesc='Single executable web server with Lua, Markdown, QUIC and Pongo2 support'
+pkgver=1.12.0
+pkgrel=1
+pkgdesc='Small self-contained web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
arch=('x86_64')
url='https://algernon.roboticoverlords.org/'
license=('MIT')
-depends=('redis')
-makedepends=('git' 'go-pie')
+makedepends=('git' 'go')
optdepends=('mariadb: For using the MariaDB/MySQL database backend'
- 'postgresql: For using the PostgreSQL database backend')
-backup=('etc/algernon/serverconf.lua'
- 'usr/lib/systemd/system/algernon.service')
+ 'postgresql: For using the PostgreSQL database backend'
+ 'redis: For using the Redis database backend')
source=("git+https://github.com/xyproto/algernon#commit=b23b6d52e0eb32581d00483e0f439d7c305434b2")
md5sums=('SKIP')
prepare() {
cd "$pkgname"
- GO111MODULE=off go build
+ go build
}
package() {
@@ -27,14 +25,16 @@ package() {
install -Dm755 algernon "$pkgdir/usr/bin/algernon"
install -Dm755 desktop/mdview "$pkgdir/usr/bin/mdview"
- install -Dm644 system/algernon_dev.service "$pkgdir/usr/lib/systemd/system/algernon.service"
install -Dm644 system/logrotate "$pkgdir/etc/logrotate.d/algernon"
install -Dm644 system/serverconf.lua "$pkgdir/etc/algernon/serverconf.lua"
- install -Dm644 desktop/algernon.desktop "$pkgdir/usr/share/applications/algernon.desktop"
- install -Dm644 desktop/algernon_md.desktop "$pkgdir/usr/share/applications/algernon_md.desktop"
+ install -Dm644 desktop/algernon.desktop \
+ "$pkgdir/usr/share/applications/algernon.desktop"
+ install -Dm644 desktop/algernon_md.desktop \
+ "$pkgdir/usr/share/applications/algernon_md.desktop"
install -Dm644 desktop/markdown.png "$pkgdir/usr/share/pixmaps/markdown.png"
- install -d "$pkgdir/usr/share/doc/$pkgname/"
- cp -r samples "$pkgdir/usr/share/doc/algernon/samples"
+ install -Dm644 system/algernon_dev.service \
+ "$pkgdir/usr/share/doc/$pkgname/algernon.service.example"
+ cp -r samples "$pkgdir/usr/share/doc/$pkgname/samples"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}