summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-10-03 21:41:32 +0200
committerAlexander F Rødseth2017-10-03 21:41:32 +0200
commit3787e5c4b55daba6194a0907cd855b89fded411c (patch)
treec042ea129f12bf479cf3f67d4e417b1aca9f1dfe
parentf0ec56f819924edef06585317f9b0f60c68ef50c (diff)
downloadaur-3787e5c4b55daba6194a0907cd855b89fded411c.tar.gz
Update to 1.6
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 658d1d2eb79e..e562ad865d7e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jul 14 12:29:53 UTC 2017
+# Tue Oct 3 19:41:21 UTC 2017
pkgbase = algernon
- pkgdesc = Pure Go web server with Lua, Markdown, HTTP/2 and template support
- pkgver = 1.5.1
+ pkgdesc = Pure Go web server with Lua, Markdown, HyperApp and Pongo2 support
+ pkgver = 1.6
pkgrel = 1
url = http://algernon.roboticoverlords.org/
arch = x86_64
@@ -10,14 +10,13 @@ pkgbase = algernon
license = MIT
makedepends = go
makedepends = git
- makedepends = glide
makedepends = setconf
optdepends = redis: For using the Redis database backend
optdepends = mariadb: For using the MariaDB/MySQL database backend
optdepends = postgresql: For using the PostgreSQL database backend
backup = etc/algernon/serverconf.lua
backup = usr/lib/systemd/system/algernon.service
- source = git+https://github.com/xyproto/algernon#tag=1.5.1
+ source = git+https://github.com/xyproto/algernon#tag=1.6
md5sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index 9b1a3a976a24..b616cbe95627 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.5.1
+pkgver=1.6
pkgrel=1
-pkgdesc='Pure Go web server with Lua, Markdown, HTTP/2 and template support'
+pkgdesc='Pure Go web server with Lua, Markdown, HyperApp and Pongo2 support'
arch=('x86_64' 'i686')
url='http://algernon.roboticoverlords.org/'
license=('MIT')
-makedepends=('go' 'git' 'glide' 'setconf')
+makedepends=('go' 'git' 'setconf')
optdepends=('redis: For using the Redis database backend'
'mariadb: For using the MariaDB/MySQL database backend'
'postgresql: For using the PostgreSQL database backend')
@@ -18,6 +18,11 @@ md5sums=('SKIP')
_gourl=github.com/xyproto/algernon
prepare() {
+ cd "$pkgname"
+ git submodule init
+ git submodule update
+ cd "$srcdir"
+
export GOROOT=/usr/lib/go
rm -rf build; mkdir -p build/go; cd build/go
@@ -36,10 +41,6 @@ prepare() {
cd "$GOPATH/src/$_gourl"
- # Manage Go dependencies with Glide
- glide update
- glide install
-
# Startup parameters
setconf system/algernon_dev.service \
ExecStart \