summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-05-10 00:33:28 +0200
committerAlexander F. Rødseth2022-05-10 00:33:28 +0200
commit433183fe699eada04ba2a5a22c4fc7efe6c8a320 (patch)
tree39563681febdfcdfa1c6feebbc0f53a194d9dbdf
parent3f51a6a075a6ffe427f24c85116812fa2201a29b (diff)
downloadaur-433183fe699eada04ba2a5a22c4fc7efe6c8a320.tar.gz
New minor release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b32af9041ec6..531d7a49104b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = algernon
pkgdesc = Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support
- pkgver = 1.12.14
+ pkgver = 1.13.0
pkgrel = 1
url = https://algernon.roboticoverlords.org/
arch = x86_64
- license = MIT
+ license = BSD
makedepends = go
optdepends = mariadb: For using the MariaDB/MySQL database backend
optdepends = postgresql: For using the PostgreSQL database backend
optdepends = redis: For using the Redis database backend
- source = algernon-1.12.14.tar.gz::https://github.com/xyproto/algernon/archive/1.12.14.tar.gz
- b2sums = 575173552d25b92717b0bca6b0be80394e1f42b24709650a334ac255eeed4845c14f25e57eba06ecaa92d0ee9d8df0b9c6087e6877223b103275884d9595af48
+ source = git+https://github.com/xyproto/algernon#commit=9181256438b9a738127b9ac202ae03c2d8b50939
+ b2sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index ed4f8019e7e2..0a3bbf308610 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.12.14
+pkgver=1.13.0
pkgrel=1
pkgdesc='Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
arch=(x86_64)
url='https://algernon.roboticoverlords.org/'
-license=(MIT)
+license=(BSD)
makedepends=(go)
optdepends=('mariadb: For using the MariaDB/MySQL database backend'
'postgresql: For using the PostgreSQL database backend'
'redis: For using the Redis database backend')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/xyproto/algernon/archive/$pkgver.tar.gz")
-b2sums=('575173552d25b92717b0bca6b0be80394e1f42b24709650a334ac255eeed4845c14f25e57eba06ecaa92d0ee9d8df0b9c6087e6877223b103275884d9595af48')
+source=("git+https://github.com/xyproto/algernon#commit=9181256438b9a738127b9ac202ae03c2d8b50939")
+b2sums=(SKIP)
prepare() {
- cd $pkgname-$pkgver
+ cd $pkgname
go build -v -mod=vendor -trimpath -buildmode=pie -ldflags="-s -w -extldflags $LDFLAGS"
}
package() {
- cd $pkgname-$pkgver
+ cd $pkgname
install -Dm755 algernon "$pkgdir/usr/bin/algernon"
install -d "$pkgdir/usr/share/doc/$pkgname/samples"
cp -r samples "$pkgdir/usr/share/doc/$pkgname/samples"