summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2016-11-25 18:12:26 +0100
committerAlexander F Rødseth2016-11-25 18:12:26 +0100
commit53c1ff853bd899a9fae553575e0b7810ff216b97 (patch)
tree0b8064a8ef164dd45689936fe53b600cfe0c55bd
parent277771f3291fead9f057ddac9b6bdcc0f311bb9c (diff)
downloadaur-53c1ff853bd899a9fae553575e0b7810ff216b97.tar.gz
Update to version 1.3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD33
2 files changed, 17 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b08cec62077..b323a0653a73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,9 @@
+# Generated by mksrcinfo v8
+# Fri Nov 25 17:12:20 UTC 2016
pkgbase = algernon
- pkgdesc = Web server with built-in support for Lua, Markdown, HTTP/2, templates, SCSS and Redis
- pkgver = 1.2.1
- pkgrel = 4
+ pkgdesc = Webi/application server with built-in support for HTTP/2, Lua, Markdown and Pongo2
+ pkgver = 1.3
+ pkgrel = 1
url = http://algernon.roboticoverlords.org/
arch = x86_64
arch = i686
@@ -15,7 +17,7 @@ pkgbase = algernon
optdepends = postgresql: For using the PostgreSQL database backend
backup = etc/algernon/serverconf.lua
backup = usr/lib/systemd/system/algernon.service
- source = git://github.com/xyproto/algernon#commit=8d43533
+ source = git://github.com/xyproto/algernon#tag=1.3
md5sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index bd44f9bf635c..017d79028437 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.2.1
-pkgrel=4
-pkgdesc='Web server with built-in support for Lua, Markdown, HTTP/2, templates, SCSS and Redis'
+pkgver=1.3
+pkgrel=1
+pkgdesc='Webi/application server with built-in support for HTTP/2, Lua, Markdown and Pongo2'
arch=('x86_64' 'i686')
url='http://algernon.roboticoverlords.org/'
license=('MIT')
@@ -13,41 +13,30 @@ optdepends=('redis: For using the Redis database backend'
'postgresql: For using the PostgreSQL database backend')
backup=('etc/algernon/serverconf.lua'
'usr/lib/systemd/system/algernon.service')
-source=("git://github.com/xyproto/algernon#commit=8d43533")
+source=("git://github.com/xyproto/algernon#tag=$pkgver")
md5sums=('SKIP')
_gourl=github.com/xyproto/algernon
prepare() {
export GOROOT=/usr/lib/go
- rm -rf build
- mkdir -p build/go
- cd build/go
-
- for f in "$GOROOT/"*; do
- ln -s "$f"
- done
-
- rm pkg
- mkdir pkg
- cd pkg
-
- for f in "$GOROOT/pkg/"*; do
- ln -s "$f"
- done
+ rm -rf build; mkdir -p build/go; cd build/go
+ for f in "$GOROOT/"*; do ln -s "$f"; done
+ rm pkg; mkdir pkg; cd pkg
+ for f in "$GOROOT/pkg/"*; do ln -s "$f"; done
export GOROOT="$srcdir/build/go"
export GOPATH="$srcdir/build"
export DESTPATH="$GOPATH/src/$_gourl"
# Make sure $DESTPATH is empty, but exists
- rm -rf "$DESTPATH"
- mkdir -p "$DESTPATH"
+ rm -rf "$DESTPATH"; mkdir -p "$DESTPATH"
mv "$srcdir/$pkgname" "$(dirname $DESTPATH)"
- # Manage Go dependencies by using Glide
cd "$GOPATH/src/$_gourl"
+
+ # Manage Go dependencies with Glide
glide update
glide install