summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-08-23 15:34:37 +0200
committerAlexander F. Rødseth2019-08-23 15:34:37 +0200
commit6f1dcbc24f8608a4ed70b58e3d1052698e8c6755 (patch)
tree3e9f2e368b8bd9d5364dcb6e2d9b1532da6c9ede
parent22b95b956f6138c855de8153b9618404c9c488e8 (diff)
downloadaur-6f1dcbc24f8608a4ed70b58e3d1052698e8c6755.tar.gz
Upgrade
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8c91d4c49912..9ad9e960c410 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
# Generated by mksrcinfo v8
-# Sat Apr 6 11:23:05 UTC 2019
+# Fri Aug 23 13:34:31 UTC 2019
pkgbase = algernon
pkgdesc = Small self-contained web server with Lua, Markdown, QUIC, Redis and PostgreSQL support
- pkgver = 1.12.4
- pkgrel = 2
+ pkgver = 1.12.5
+ pkgrel = 1
url = https://algernon.roboticoverlords.org/
arch = x86_64
license = MIT
makedepends = git
makedepends = go
+ makedepends = upx
optdepends = mariadb: For using the MariaDB/MySQL database backend
optdepends = postgresql: For using the PostgreSQL database backend
optdepends = redis: For using the Redis database backend
- source = git+https://github.com/xyproto/algernon#tag=1.12.4
+ source = git+https://github.com/xyproto/algernon#tag=1.12.5
md5sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index e72815972fc7..d5e983acba74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.12.4
-pkgrel=2
+pkgver=1.12.5
+pkgrel=1
pkgdesc='Small self-contained web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
arch=(x86_64)
url='https://algernon.roboticoverlords.org/'
license=(MIT)
-makedepends=(git go)
+makedepends=(git go upx)
optdepends=('mariadb: For using the MariaDB/MySQL database backend'
'postgresql: For using the PostgreSQL database backend'
'redis: For using the Redis database backend')
@@ -17,6 +17,7 @@ md5sums=('SKIP')
prepare() {
cd "$pkgname"
go build -mod=vendor -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
+ upx algernon
}
package() {