summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2018-10-31 12:31:16 +0100
committerAlexander F. Rødseth2018-10-31 12:31:16 +0100
commit6ff1560b6e37b69457bf178da9068abf44ef1dee (patch)
tree7b4d7b7b516659b3b4b8a28bf9a280971d179a01
parenta9a314f027f58e4ee912f6df33b5b2cdcf83943e (diff)
downloadaur-6ff1560b6e37b69457bf178da9068abf44ef1dee.tar.gz
Update to use go-pie and vendored dependencies
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD42
2 files changed, 9 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f16a72d1dd95..62b4e04b7181 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
# Generated by mksrcinfo v8
-# Wed Sep 12 10:22:59 UTC 2018
+# Wed Oct 31 11:31:07 UTC 2018
pkgbase = algernon
pkgdesc = Single executable web server with Lua, Markdown, QUIC and Pongo2 support
pkgver = 1.11.0
- pkgrel = 1
+ pkgrel = 2
url = https://algernon.roboticoverlords.org/
arch = x86_64
license = MIT
makedepends = git
- makedepends = go
+ makedepends = go-pie
depends = redis
optdepends = mariadb: For using the MariaDB/MySQL database backend
optdepends = postgresql: For using the PostgreSQL database backend
backup = etc/algernon/serverconf.lua
backup = usr/lib/systemd/system/algernon.service
- source = git+https://github.com/xyproto/algernon#tag=1.11.0
+ source = git+https://github.com/xyproto/algernon#commit=b23b6d52e0eb32581d00483e0f439d7c305434b2
md5sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index 71b06880d15a..58798be682ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,60 +2,28 @@
pkgname=algernon
pkgver=1.11.0
-pkgrel=1
+pkgrel=2
pkgdesc='Single executable web server with Lua, Markdown, QUIC and Pongo2 support'
arch=('x86_64')
url='https://algernon.roboticoverlords.org/'
license=('MIT')
depends=('redis')
-makedepends=('git' 'go')
+makedepends=('git' 'go-pie')
optdepends=('mariadb: For using the MariaDB/MySQL database backend'
'postgresql: For using the PostgreSQL database backend')
backup=('etc/algernon/serverconf.lua'
'usr/lib/systemd/system/algernon.service')
-source=("git+https://github.com/xyproto/algernon#tag=$pkgver")
+source=("git+https://github.com/xyproto/algernon#commit=b23b6d52e0eb32581d00483e0f439d7c305434b2")
md5sums=('SKIP')
-_gourl=github.com/xyproto/algernon
prepare() {
cd "$pkgname"
- git submodule init
- git submodule update
-
- cd "$srcdir"
-
- export GOROOT=/usr/lib/go
-
- rm -rf build; mkdir -p build/go; cd build/go
- for f in "$GOROOT/"*; do ln -s "$f"; done
- rm pkg; mkdir pkg; cd pkg
- for f in "$GOROOT/pkg/"*; do ln -s "$f"; done
-
- export GOPATH="$srcdir/build"
- export GOROOT="$GOPATH/go"
- export DESTPATH="$GOPATH/src/$_gourl"
-
- # Make sure $DESTPATH is empty, but exists
- rm -rf "$DESTPATH"; mkdir -p "$DESTPATH"
-
- mv "$srcdir/$pkgname" "$(dirname $DESTPATH)"
-}
-
-build() {
- cd "$GOPATH/src/$_gourl"
-
- go build -x
-}
-
-check() {
- cd "$GOPATH/src/$_gourl"
-
- go test
+ GO111MODULE=off go build
}
package() {
- cd "$GOPATH/src/$_gourl"
+ cd "$pkgname"
install -Dm755 algernon "$pkgdir/usr/bin/algernon"
install -Dm755 desktop/mdview "$pkgdir/usr/bin/mdview"