summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-02-19 21:01:00 +0100
committerAlexander F. Rødseth2019-02-19 21:01:00 +0100
commit8054d572a50e5116f478b1a01cb892370fb2d1c0 (patch)
treefed966229c6d7d3e0cfda9203487fee5d0debe04
parentdf06a145fb02c18f44553f998710257696c982de (diff)
downloadaur-8054d572a50e5116f478b1a01cb892370fb2d1c0.tar.gz
Upgrade to the latest release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2759b33b408..980852a12c74 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Nov 1 13:11:52 UTC 2018
+# Tue Feb 19 20:00:54 UTC 2019
pkgbase = algernon
pkgdesc = Small self-contained web server with Lua, Markdown, QUIC, Redis and PostgreSQL support
- pkgver = 1.12.0
- pkgrel = 2
+ pkgver = 1.12.3
+ pkgrel = 1
url = https://algernon.roboticoverlords.org/
arch = x86_64
license = MIT
@@ -12,7 +12,7 @@ pkgbase = algernon
optdepends = mariadb: For using the MariaDB/MySQL database backend
optdepends = postgresql: For using the PostgreSQL database backend
optdepends = redis: For using the Redis database backend
- source = git+https://github.com/xyproto/algernon#tag=1.12.0
+ source = git+https://github.com/xyproto/algernon#tag=1.12.3
md5sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index 4e27d03e6554..235b795411d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.12.0
-pkgrel=2
+pkgver=1.12.3
+pkgrel=1
pkgdesc='Small self-contained web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
-arch=('x86_64')
+arch=(x86_64)
url='https://algernon.roboticoverlords.org/'
-license=('MIT')
-makedepends=('git' 'go')
+license=(MIT)
+makedepends=(git go)
optdepends=('mariadb: For using the MariaDB/MySQL database backend'
'postgresql: For using the PostgreSQL database backend'
'redis: For using the Redis database backend')
@@ -16,8 +16,7 @@ md5sums=('SKIP')
prepare() {
cd "$pkgname"
-
- go build
+ go build -gcflags "all=-trimpath=${PWD}" -asmflags "all=-trimpath=${PWD}" -ldflags "-extldflags ${LDFLAGS}"
}
package() {