summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2017-06-01 15:29:17 +0200
committerAlexander F Rødseth2017-06-01 15:29:17 +0200
commit8065294fd4a33e584752185595ed3dd24c4f3e75 (patch)
tree4c19c53235ed07a7c0769515c42d79637986fddb
parent9faf41267640f9948413f3e9bf5594ab48db4e68 (diff)
downloadaur-8065294fd4a33e584752185595ed3dd24c4f3e75.tar.gz
Upgrade to 1.4.4
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a66faadb0c05..9f782db68387 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Thu May 25 21:02:38 UTC 2017
+# Thu Jun 1 13:29:11 UTC 2017
pkgbase = algernon
- pkgdesc = Pure Go web server with built-in support for HTTP/2, Markdown, Lua and templates
- pkgver = 1.4.2
+ pkgdesc = Pure Go web server with Lua, Markdown, HTTP/2 and template support
+ pkgver = 1.4.4
pkgrel = 1
url = http://algernon.roboticoverlords.org/
arch = x86_64
@@ -17,7 +17,7 @@ pkgbase = algernon
optdepends = postgresql: For using the PostgreSQL database backend
backup = etc/algernon/serverconf.lua
backup = usr/lib/systemd/system/algernon.service
- source = git+https://github.com/xyproto/algernon#tag=1.4.2
+ source = git+https://github.com/xyproto/algernon#commit=59a3b8dc65adc72352771a4cf1ab474fccfb386c
md5sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index 2c00569a3e70..68f42d3da2b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.4.2
+pkgver=1.4.4
pkgrel=1
-pkgdesc='Pure Go web server with built-in support for HTTP/2, Markdown, Lua and templates'
+pkgdesc='Pure Go web server with Lua, Markdown, HTTP/2 and template support'
arch=('x86_64' 'i686')
url='http://algernon.roboticoverlords.org/'
license=('MIT')
@@ -13,7 +13,7 @@ optdepends=('redis: For using the Redis database backend'
'postgresql: For using the PostgreSQL database backend')
backup=('etc/algernon/serverconf.lua'
'usr/lib/systemd/system/algernon.service')
-source=("git+https://github.com/xyproto/algernon#tag=$pkgver")
+source=("git+https://github.com/xyproto/algernon#commit=59a3b8dc65adc72352771a4cf1ab474fccfb386c")
md5sums=('SKIP')
_gourl=github.com/xyproto/algernon
@@ -25,8 +25,8 @@ prepare() {
rm pkg; mkdir pkg; cd pkg
for f in "$GOROOT/pkg/"*; do ln -s "$f"; done
- export GOROOT="$srcdir/build/go"
export GOPATH="$srcdir/build"
+ export GOROOT="$GOPATH/go"
export DESTPATH="$GOPATH/src/$_gourl"
# Make sure $DESTPATH is empty, but exists
@@ -53,6 +53,12 @@ build() {
go build -x
}
+check() {
+ cd "$GOPATH/src/$_gourl"
+
+ ./test.sh
+}
+
package() {
cd "$GOPATH/src/$_gourl"