summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2016-09-21 13:52:31 +0200
committerAlexander F Rødseth2016-09-21 13:52:31 +0200
commit8137c9f5b7cb292dc5492aae99629ba11f828ecf (patch)
treed078349670e8a9a491ee1fa65bcf2d9629b0c2e6
parentca1f424a4dec5c1ff90d7b26761db4253706b275 (diff)
downloadaur-8137c9f5b7cb292dc5492aae99629ba11f828ecf.tar.gz
Upgrade to 1.2
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 16 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ee8251a2c08..f84b76595b09 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jun 5 19:45:21 UTC 2016
+# Wed Sep 21 11:52:24 UTC 2016
pkgbase = algernon
- pkgdesc = HTTP/2 web server with built-in support for Markdown, Lua, Pongo2, JSX and Redis
- pkgver = 1.0
+ pkgdesc = HTTP/2 web server with built-in support for Markdown, Lua, Sass (SCSS), JSX and Redis
+ pkgver = 1.2
pkgrel = 1
url = http://algernon.roboticoverlords.org/
install = algernon.install
@@ -11,9 +11,12 @@ pkgbase = algernon
license = MIT
makedepends = go
makedepends = git
- optdepends = redis
+ makedepends = glide
+ optdepends = redis: For using the Redis database backend
+ optdepends = mariadb: For using the MariaDB/MySQL database backend
+ optdepends = postgresql: For using the PostgreSQL database backend
backup = etc/algernon/serverconf.lua
- source = git://github.com/xyproto/algernon#tag=1.0
+ source = git://github.com/xyproto/algernon#tag=1.2
md5sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index 1e0488838bab..ed066b97b50b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,16 @@
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.0
+pkgver=1.2
pkgrel=1
-pkgdesc='HTTP/2 web server with built-in support for Markdown, Lua, Pongo2, JSX and Redis'
+pkgdesc='HTTP/2 web server with built-in support for Markdown, Lua, Sass (SCSS), JSX and Redis'
arch=('x86_64' 'i686')
url='http://algernon.roboticoverlords.org/'
license=('MIT')
-makedepends=('go' 'git')
-optdepends=('redis')
+makedepends=('go' 'git' 'glide')
+optdepends=('redis: For using the Redis database backend'
+ 'mariadb: For using the MariaDB/MySQL database backend'
+ 'postgresql: For using the PostgreSQL database backend')
backup=('etc/algernon/serverconf.lua')
source=("git://github.com/xyproto/algernon#tag=$pkgver")
md5sums=('SKIP')
@@ -17,13 +19,13 @@ install='algernon.install'
prepare() {
cd "$pkgname"
- GOPATH="$srcdir" go get -d
+ glide install
}
build() {
cd "$pkgname"
- GOPATH="$srcdir" go build
+ go build
}
package() {