summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F Rødseth2018-04-06 10:28:33 +0200
committerAlexander F Rødseth2018-04-06 10:28:33 +0200
commitf0335718c4b219eab4f577024cebd7b5f7e468df (patch)
tree8df396d9bac86fa3efe95b726cf8dda4778b0796
parentb5461ef1562e433a85b945faa6e0596575ade08b (diff)
downloadaur-f0335718c4b219eab4f577024cebd7b5f7e468df.tar.gz
New release
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dfd27555ba49..2471f7d74317 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
# Generated by mksrcinfo v8
-# Mon Jan 15 13:08:08 UTC 2018
+# Fri Apr 6 08:28:21 UTC 2018
pkgbase = algernon
pkgdesc = Single executable web server with Lua, Markdown, QUIC and Pongo2 support
- pkgver = 1.8
+ pkgver = 1.9
pkgrel = 1
- url = http://algernon.roboticoverlords.org/
+ url = https://algernon.roboticoverlords.org/
arch = x86_64
arch = i686
license = MIT
@@ -16,7 +16,7 @@ pkgbase = algernon
optdepends = postgresql: For using the PostgreSQL database backend
backup = etc/algernon/serverconf.lua
backup = usr/lib/systemd/system/algernon.service
- source = git+https://github.com/xyproto/algernon#tag=1.8
+ source = git+https://github.com/xyproto/algernon#tag=1.9
md5sums = SKIP
pkgname = algernon
diff --git a/PKGBUILD b/PKGBUILD
index d05dccec16fe..2116232b7c64 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
pkgname=algernon
-pkgver=1.8
+pkgver=1.9
pkgrel=1
pkgdesc='Single executable web server with Lua, Markdown, QUIC and Pongo2 support'
arch=('x86_64' 'i686')
-url='http://algernon.roboticoverlords.org/'
+url='https://algernon.roboticoverlords.org/'
license=('MIT')
makedepends=('git' 'go' 'setconf')
optdepends=('redis: For using the Redis database backend'
@@ -13,14 +13,16 @@ optdepends=('redis: For using the Redis database backend'
'postgresql: For using the PostgreSQL database backend')
backup=('etc/algernon/serverconf.lua'
'usr/lib/systemd/system/algernon.service')
-source=('git+https://github.com/xyproto/algernon#tag=1.8')
+source=("git+https://github.com/xyproto/algernon#tag=$pkgver")
md5sums=('SKIP')
_gourl=github.com/xyproto/algernon
prepare() {
cd "$pkgname"
+
git submodule init
git submodule update
+
cd "$srcdir"
export GOROOT=/usr/lib/go
@@ -42,9 +44,9 @@ prepare() {
cd "$GOPATH/src/$_gourl"
# Startup parameters
- setconf system/algernon_dev.service \
- ExecStart \
+ setconf system/algernon_dev.service ExecStart \
"/usr/bin/algernon -e -a --domain --server --log /var/log/algernon.log --addr=:80 /srv/http"
+
setconf system/algernon_dev.service Group=http
}