summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2022-05-10 00:30:17 +0200
committerAlexander F. Rødseth2022-05-10 00:30:17 +0200
commit14ed0bdbfa67fff7d59cb002a3327756eaed8bc4 (patch)
tree1bb7792a2c3d37d4c3bea8aea07d50a074e261d7
downloadaur-14ed0bdbfa67fff7d59cb002a3327756eaed8bc4.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD24
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..539319efd688
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = algernon-bin
+ pkgdesc = Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support
+ pkgver = 1.13.0
+ pkgrel = 1
+ url = https://algernon.roboticoverlords.org/
+ arch = x86_64
+ license = BSD
+ makedepends = go
+ optdepends = mariadb: For using the MariaDB/MySQL database backend
+ optdepends = postgresql: For using the PostgreSQL database backend
+ optdepends = redis: For using the Redis database backend
+ conflicts = algernon
+ replaces = algernon
+ source = algernon-1.13.0.tar.gz::https://github.com/xyproto/algernon/releases/download/v1.13.0/algernon-1.13.0-linux_x86_64_static.tar.xz
+ b2sums = bd2a56b01850c1040ef1f63dd4fcc0b3b0c45dbac9251f3864d2cc9b9c3bc8b8fe8905e180274105c7bd9f5004a7d37a1627d60ddd33fa3f10e67b76f81422b1
+
+pkgname = algernon-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..18517c276ed6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=algernon-bin
+pkgver=1.13.0
+pkgrel=1
+pkgdesc='Web server with Lua, Markdown, QUIC, Redis and PostgreSQL support'
+arch=(x86_64)
+url='https://algernon.roboticoverlords.org/'
+license=(BSD)
+makedepends=(go)
+conflicts=(algernon)
+replaces=(algernon)
+optdepends=('mariadb: For using the MariaDB/MySQL database backend'
+ 'postgresql: For using the PostgreSQL database backend'
+ 'redis: For using the Redis database backend')
+source=("algernon-$pkgver.tar.gz::https://github.com/xyproto/algernon/releases/download/v$pkgver/algernon-${pkgver}-linux_${CARCH}_static.tar.xz")
+b2sums=('bd2a56b01850c1040ef1f63dd4fcc0b3b0c45dbac9251f3864d2cc9b9c3bc8b8fe8905e180274105c7bd9f5004a7d37a1627d60ddd33fa3f10e67b76f81422b1')
+
+package() {
+ cd algernon-${pkgver}-linux_${CARCH}_static
+ install -Dm755 algernon "$pkgdir/usr/bin/algernon"
+ install -Dm644 algernon.1.gz "$pkgdir/usr/share/man/man1/algernon.1.gz"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/algernon/LICENSE"
+}