summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrzej Giniewicz2015-07-07 21:32:54 +0200
committerAndrzej Giniewicz2015-07-07 21:32:54 +0200
commitcc06f473683904ad0559a6fc1cce08b8c3443d53 (patch)
tree380c1c27830e8a2a93cd51375c42a77c0d53e4c4
downloadaur-alglib-fpc.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
-rw-r--r--comments.patch11
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad824da7fecb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = alglib-fpc
+ pkgdesc = FreePascal version of ALGLIB, a numerical analysis and data processing library
+ pkgver = 2.6.0
+ pkgrel = 1
+ url = http://www.alglib.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = fpc
+ options = !strip
+ source = http://www.alglib.net/translator/re/alglib-2.6.0.freepascal.zip
+ source = comments.patch
+ md5sums = 204a2fd5d8fd9a5d6ba3cb190615e667
+ md5sums = 5ec1c728d1aeec7d6b7b4babb65f5584
+
+pkgname = alglib-fpc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dc6b50b71ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Andrzej Giniewicz <gginiu@gmail.com>
+pkgname=alglib-fpc
+pkgver=2.6.0
+pkgrel=1
+pkgdesc="FreePascal version of ALGLIB, a numerical analysis and data processing library"
+arch=('i686' 'x86_64')
+url="http://www.alglib.net/"
+license=('GPL')
+depends=(fpc)
+options=(!strip)
+source=("http://www.alglib.net/translator/re/alglib-$pkgver.freepascal.zip"
+ comments.patch)
+md5sums=('204a2fd5d8fd9a5d6ba3cb190615e667'
+ '5ec1c728d1aeec7d6b7b4babb65f5584')
+
+build() {
+ cd "$srcdir/freepascal/src"
+ patch -p0 < ../../comments.patch
+ for file in `ls *.pas`
+ do
+ fpc $file
+ done
+}
+
+package(){
+ cd "$srcdir/freepascal/src"
+ _target="$pkgdir/usr/lib/fpc/`fpc -iV`/units/`fpc -iSP`-`fpc -iSO`/alglib"
+ install -d -m755 "$_target"
+ install -D -m644 {*.o,*.ppu} "$_target"/
+}
+
diff --git a/comments.patch b/comments.patch
new file mode 100644
index 000000000000..9f266075417d
--- /dev/null
+++ b/comments.patch
@@ -0,0 +1,11 @@
+--- jacobianelliptic.pas.orig 2012-01-05 15:02:55.000000000 +0100
++++ jacobianelliptic.pas 2012-01-05 15:03:06.000000000 +0100
+@@ -64,7 +64,7 @@
+ Tested at random points with u between 0 and 10, m between
+ 0 and 1.
+
+- Absolute error (* = relative error):
++ Absolute error ( * = relative error ):
+ arithmetic function # trials peak rms
+ IEEE phi 10000 9.2e-16* 1.4e-16*
+ IEEE sn 50000 4.1e-15 4.6e-16